Changes after applying lattice

Hopefully someone can help with this issue. I am using a lattice modifier to modify a mesh. I get things looking like I want them, and then when I apply the lattice, the mesh changes, not much, but enough to matter to me. The only other modifier on the mesh is a subsurf and I’ve tried moving the lattice up and down in the stack before I apply it, but keep getting the same result. Attached are a couple of screen shots showing the change before and after applying the modifier. Hopefully the pics are clear enough for you to see the difference.



I don´t see any difference :stuck_out_tongue: but you might try to be sure your pivots are exactly the same locations, to make sure the are no offsets, also no rotations, translations or scales for both objects, can´t figure out other, hope this helps.

Hi Raw Recruit,
I doubt I’m going to be any help, except to say I see what you’re talking about. It’s easy to see if you open the two attachments in separate tabs and switch back and forth between them. The breasts shrink and the pinch near the arm hole gets worse.

Do anim gifs work here???

http://bentfx.com/BlenderArtistsForum/Untitled.gif

I was able to get it applied and keep the shape by applying the subsurf first and then applying the lattice. Which is great, except that I would still like to be using that subsurf modifier. If anyone has any ideas, I’d love to hear them, and thanks for the help offered so far, it’s much appreciated.

Was your lattice originally above or below the subsurf mod in the modifier stack?

Bump the subsurf down to 0 in the viewport, then apply the lattice and crank the subsurf back up. From my simple testing that seems to work. And yes I see the same behavior just using a simple sphere.

EDIT: To verify, duplicate the object before you apply the lattice. Then after you apply the lattice and re-subsurf a simple scale should show that the whole surface disappears at once when you scale it on top of the other. It was that creating a duplicate that showed me how much the subsurf deformed when the lattice was applied.

I had never used a lattice in Blender. Buffing on my mAdSk1IIz

EDIT AGAIN: I played with it some more. I can’t reproduce the same problem if the lattice is at the top of the stack. If you’re having the problem with the lattice top of the stack… Then… I dunno!

Lattice was originally below the subsurf. If I move it up the stack I get the same changes, even before applying.

I gave this a whirl and got the same changes.

Thanks.