Changing default physics engine

I’ve tried to change the default physics engine to none by changing the code in the file world.c

wrld->physicsEngine= WOPHY_BULLET


wrld->physicsEngine= WOPHY_NONE

I know that the code is right but it ain’t changing it. Is it in the right file? Even if I delete that part, bullet is still selected by default, is something else changing the default engine?

Why on earth would you want to change the physics engine? anyway it’s not active if all you have is static ghosts

This is completely the wrong forum for this…

99% of the people on this forum will have no idea that you’re modifying the source. Go to some of the forums on, and look around on the development page…

I know this is gonna sound like a stupid question, but it had to be asked: did you compile after changing the source?

did you delete your .B.blend (and modify the default one compiled in)? note that the setting is saved in DNA, so when opening .B.blend to load defaults it will overwrite what you put in the struct

Ah, now I understand, figured you were trying to disable the engine with python ingame

@Captain Oblivion: Yea, I’m not that stupid.
@cyborg_ar: I didn’t do anything to any B.blend, I look further into that.

But, I’ve noticed that if I chuck that code in somewhere else like the logic panel, it’ll change to “none” as soon as I enter the logic panel, so does anyone know when world.c runs?
Also when I delete that part from world.c, bullet is still enabled by default so something else must be enabling it.

Also I still want bullet as an option, I just want “none” there by default.

to do that you just gotta edit .B.blend

edit: attached my .B.blend with the setting you want


60f0fd6b38d60f6acc9201db8f5b794b.B.blend (145 KB)