Changing Frame in Timeline Tanks Performance


I’m not exactly a Blender noob, been messing with the program for about 6 years now, but only recently doubled down on honing my skills. In fact, I’ve asked questions on this forum before, but decided to make a new account sporting my studio name.

In one of my recent animations, things seemed to be going well. I had Simplify on, and hid anything unnecessary for the viewport. When the Timeline was set to AV-Sync, it seemed to run well for a quick preview. All of a sudden in the middle of work, I pressed Play, but while the accompanying dialogue sound-strip played, Blender seemed to freeze (Not Responding). Every time I go to change the frame now, Blender locks up for about 30 seconds or more before letting me do anything. If I press play, it takes about 2 minutes before I can stop it. I also noticed it takes much longer to open the file.

The viewport is running smoothly, it’s just the timeline. So odd. My laptop is not the fastest in the world, but can hold it’s own with WoW and Ark: Survival Evolved, and has up until now worked moderately well with Blender. I figure this has got to be some freak issue, or hopefully something well known. I can’t think of anything I did to cause this. I appended a character and edited the textures on another (I used 2D animated facial expressions in which the visibility is turned on or off for certain expressions) but I didn’t do anything I normally wouldn’t. This is not something that happened gradually either. I messed around with the characters for sometime before it decided to chug.

I have zipped and uploaded the .blend file in question in case you want to take a look at it. I hope you can help me! Thanks in advance! :slight_smile:

Blend file found here:
(Link removed, case solved)

EDIT: It was found that 3 similar objects we’re causing the tank in performance, but looking at the objects it’s hard to tell what went wrong. Further investigation commences.