Changing the camera view

Hi,

I’m having trouble making the camera look upwards. At the moment, it’s looking down on my mesh, but I want it to look at it horizontally. How might I do this? The tutorials I have seen don’t explain it…

Thanks,

lancerr

You can move/rotate the camera while looking through it, but it’s easier if you have at least one or two … or even 3 3d views open. So with 3, 3dviews, make one the camera view (NUMPAD 0), and the other two a top and front or top/side etc. Make sure they are orthographic (NUMPAD5) views, to be able to position the camera accurately.

Turning on the 3d manipulator (CTR-SPACE or the "hand icon)) can help … switch it to “combo” mode (by either CTR-SPACE “combo” from the menu), or by shift clicking on the translate/rotator icons).

Another handy trick is to rotate / pan the 3d view to the viewpoint you want of your model then press CTRL-ALT-NUMPAD0 (or view/align view/ align active camera to view ) to position and align the camera to match up with the 3d view.

Something else you might want to do is to assign a “Track To” constraint to the camera. Add an Empty to the scene, then select the camera, and SHIFT-RMB select the Empty, then press CTR-T / and choose TrackTo constraint from the popup. Now you can move the Empty to wherever you want the camera to aim at, and you can still move the camera to change the angle etc. Go to the constraint panel (F7) and you can turn the trackto constraint on or off by adjusting the Influence slider. You can keyframe the influence by pressing the Key button.

Mike

Thank you for all those tips, especially the CTRL+ALT+NUMPAD0! That one is hugely helpful :wink:

Cheers!

I have one last question (which is slightly unrelated, but I don’t want to start another thread). My render is a bit jagged, especially on the edges, and I have tried smoothing it but to little effect. Here’s a screenshot:

http://img457.imageshack.us/img457/9850/bowl1cd5.th.jpg

And the settings:

The object has been:

  • Set Smooth
  • Subserfed: subdiv = 2, render = 2

The rendering settings:

  • OSA enabled
  • OSA level = 8

I had to render it and take a screenshot, because I haven’t quite figured out how to export an image of it on Blender 2.35 :wink:

Do you know how I can get rid of the jaggedness, or will exporting the image the proper way get rid of them?

Thank you :slight_smile:

The model is probably jagged because of the way you modelled it – can’t tell for sure without seeing the wire. When using subsurfs if you have triangles near creases and edges you will get artifacts. File->Save Image to save render.

GreyBeard

Here are some images:

http://img343.imageshack.us/img343/7555/bowl1picsjn4.th.jpg

I can upload the .blend file if you want :slight_smile:

When using subsurfs if you have triangles near creases and edges you will get artifacts. File->Save Image to save render.
Ah… So the “artifacts” are the jagged parts?

And thanks for the File->Save Image hint :smiley:

//edit: I created the mesh by adding a UVsphere, removing a few vertices and extruding the edges… I also used the knife tool in a few places, and Shift+E to sharpen some edges. So, I don’t know what I might have done wrong :confused:

Thank you in advance.

Actually your model looks pretty good. Perhaps you have some verts on top of each other. try selecting all the verts and w->remove doubles. If that doesn’t work post the blend

GreyBeard

Hmm… After removing the 111 doubles (eek):

http://img259.imageshack.us/img259/5961/bowl1hr6.th.jpg

Hehe! Here’s the .blend: http://www.box.net/public/b47yydtzuz

Thanks :slight_smile:

Select all the verts and press ctrl-n to get rid of the dark banding

GreyBeard

Excellent! The edges are still a bit jagged, but much less so… Thanks! :smiley:

lancerr

Well, I used a lot the TrackTo Constraint command while at the GingerbreadMan tutorial. So, I got better at Modeling, but suddenly, when I tried to center the camera, like I used to (Ctrl+T, TrackTo Constraint), I see no pop-up menu! What is wrong? I re-reinstalled it, tried the noninstall version, but nothing! I cannot activate the function! Please help, soon!

Make sure you’re pressing CTR-T and not CTR-SHIFT-T.

Otherwise I can’t think of any other reason for it not to work.

Mike

Hi,

It looks jagged because you have taken a screenshot of the render window and your render is larger than that window. Blender has resized your render to display it in this window but it doesn’t do a very good job! Save the render somewhere (F3) and open it in an external image viewer to see it properly.

These work in the image viewer if that’s what you have your render output set to (not render window).
NUM1 - zoom 1:1 (gets rid of resize aliasing w/o having to export to another viewer)
NUM2 - zoom 2:1
NUM4 - zoom 4:1
NUM8 - zoom 8:1

Numpad + works too.

%<

Well, thanks, Tony, but that didn’t help.:o Only that a week later, (but I used this command A LOT, like everytime) I find out that the Hotkey at NVidia (set by me) was for Window Transparency CTRL+T… And since it can be changed, I did it. Then I analysed the thing. Blender uses OpenGL, which nulls the Transparency, NVidia has no message for that, so they cancel each other out, since Blender has no authority to submine the othe r command. (Any commercial use of the TM NVidia text is and will be sanctioned:confused: :confused: ).:slight_smile:

And Mike_S too, by the way, thanks a lot!