Changing the Selected Bone in Weight Painting Mode?

Hi All,

Whether or not the selected bone can be changed while in Weight Paint mode seems to depend on how User Preferences -> Input -> Select With has been set.

I like working with the LMB rather than the RMB and so I have it set that way. It’s been a while since I did any weight painting, but I have a vague memory of being able to switch bones while doing so. But for some reason, I can’t. I’ve tried every combination of qualifiers and mouse buttons I can think of but the only thing that seems to work is to switch my preferences to use the RMB for Select With.

So, I have some questions:

  • Has something changed in recent builds that affects this behaviour?
  • Is it a bug?
  • Is there a way to do this without having to change my preferences?

ensure the armature is in pose mode before selecting the mesh and using weight painting… If the armature is in object mode beforehand, you will not be able to select bones. Its a feature in blender which means you can select a mesh whilst in pose mode of an armature, otherwise you would have to manually select the vertex groups.

Thanks for jumping in, Exile420. That’s the way it’s supposed to work, but it only works that way when you have RMB as your select button. If you use the LMB, it doesn’t work… or at least, the qualifier key eludes me. I’m pretty sure it did work a couple of months ago if I held down either Ctrl or Shift or Alt, but not now.

Sorry if this wasn’t clear in my first message.

For now, I’ve resigned myself to switching my preferences to RMB while weight painting, then switching it back afterwards.

LMB select option is a Blender feature and should work throughout the app. You should file a bug report.

A similar issue (LMB in the curve editors) was fixed a few months ago… after it was reported. :slight_smile:

-LP

aah sincere apologies , I must have misread the question… Unfortunately it does seem to be a bug (I tried it and got the same problem in 2.65a), the LMB option should work for everything :frowning:

I agree reporting it would be the best option, if you know python (which I dont) you or someone else could make a small script to change the LMB option whenever you enter weight painting mode (until its fixed)

I looked through the bug database and there is an outstanding report for this filed back in August. Interestingly, the response stated that they have a list of these problems, but they aren’t considered bugs.

That’s why I hesitate to report bugs. I’ve seen that type of thing several other times where the devs reply “this isn’t a bug.” I don’t understand that. You can call it a mammal or a crustacean if you want, but if it doesn’t work the way it’s supposed to, that comes under the heading ichthyology.

@Exile420: No worries. :slight_smile:

Looks like there was a workaround mentioned in a separate bug report…
changed to Ctrl+LMB as of today.


Revision 54453 by Campbell Barton (/trunk/blender) 12 hours 6 min ago
fix [#34143] Can’t Select Bones in Weight paint mode with Left mouse Selection enabled
use action-mouse for weight-sample and weight-sample-group rather then left mouse.

Alt+Left-Mouse more or less worked by accident, changing these keymaps makes it so Ctrl+LMB can be used for selection instead.

http://www.miikahweb.com/en/blender/svn-logs/commit/54453
http://projects.blender.org/tracker/index.php?func=detail&aid=34143

-LP

Thanks, Larry. I’ll grab a more recent build.

I was playing around with an earlier version of Blender yesterday (2.57 or 2.60, somewhere in there) and almost fell off my chair when LMB moved the Timeline marker. :slight_smile: I forgot it ever did.