char model mangling and GE runtime crash problem

This is a char select screen in which the camera rotates around a platform with the characters on it. When I press ‘P’ in blender I get this…

But when I export into a runtime I get this…

Also, in blender the rotation of the camer along the lpo’s is flawless back and forth. In the runtime however if the mouse is moved while clicked on top of either of the arrows the whole thing blows up in a horrible crash in an unhandled win32 exception…

notice how the green persons legs arent bent in the runtime.
that means either there is either a system problem, a blender bug, but more likely you dont have enable all frames on or it is just not on frame one.
the crashing is do to a argument becauuse you have it clicked but you moved it thus making it confused on whether to urn or not thus resulting in said crash.
all theoretical.

Green’s person’s legs are screwed up too, they’re in a triangle shape so it’s hard to tell from the side. Enable all frames isn’t a fix (tried it)
As for the crash, I think it’s a hardware issue.

Tried without a fix:

  • changing “Enable all frames”
  • changing “Use Blender Materials”
  • reviewed and changed the python code for hours
  • reviewed and changed my logic bricks for hoursNothing seems to affect the mangling of my char models, nor fix the crash problem. I’ve tried going to a different computer and it seemed to fix the crash, but not the char model mangling…Like I said it works 100% fine within the blender environment, but the runtime just dies. It sends an unhandled win32 exception and provides no debug information whatsoever.
    Any help on this?

It just keeps getting better!
I figured it must be some sort of problem dealing with the animation of the camera, since that was the only thing actually moving, turns out I was ALL wrong.
Instead of spinning the camera around the platform (which wasn’t the smartest idea anyway,I simply wanted to learn how to manipulate lpo curves to make something move over a curved path) I made the platform spin. So I moved the armatures to layer 1, parented them to the platform, and make the platform spin instead of the camera…when I did so everything flipped out.

Just an additional comment on that last post, it worked fine within blender as well, it’s the runtime that flips out.

I reported the same thing a week ago:

I think the problem is that bones ruled by a IK constraint don’t work as expected in the EXE version. In fact they seem to be relocated at the center of the skeleton. The part of the mesh attached to them are also sent to the same black hole, so the legs vanish.

Try the 2.37a version: bone’s constraints don’t work at all (nor in blender niether in the exe) but the baked version of the action plays as espected in both environments.


That actually makes a lot of sense, although to fully use it I would have to redo 4 complete characters’ entire rigging and with a due date being less than 24 hours away I think it’s best I work on the last one or two necessities and stick to my workaround…
What’s the workaround you say? Deleting the legs and hiding the bottom half of the character! :smiley: