Character Animation in Epic Scene problem

So I’m making a short film and I have a grand market scene with lots of fruits and vegetables and things. Now I need to animate my main characters in this scene. The problem is memory. My computer can’t handle a scene this large. Blender sometimes crashes when I work with a scene this large. On top of that, there are some secondary characters with animation like walks, looking for food items, and so on and they’re all low-poly. The times when Blender doesn’t crash, animating the characters becomes a pain as it becomes slow and sometimes freezes. Is there any way I can hide the heavy scene and work with my character animation separately? I tried putting my main characters on a separate layer, but still same problems persist.

Also, I’m not worrying about the rendering since can handle a file this big (320MB).
I just want to find a way to animate my characters smoothly at 24fps in a large, epic scene with no freezes and crashes and in a scene filled with about 20 secondary characters all containing animation data associated with them.


From the book of old tricks; any background images should be rendered once, then projected onto flat planes like a scene backdrop.

Thanks Lancer,
But this will be tough, since this scene involves a camera flying through the market place to show how big it is. The main characters in the scene will be running through the market place with excitement and this needs to be animated. It is only a 30-second animation but covers pretty much the entire market place in one shot.

Wow - sounds like something outta Sintel. The same basis applies though. The idea is you bake surface textures onto basic shapes. With a diffuse map (colour), spec map and normal map on a cube, it can look very much like a high poly wooden crate.
Big productions with the luxury of more people assign a certain number of texture artists for this reason. I know that at industry level, a lot of my Maya friends make renders in different passes (one for colour, another for ambient occlusion, etc… even different passes for each of several lights) so that they can overlay them all into one composited shot and tweak the perfect lighting values in post. It’s more work, but the computes can generate the shots much more efficiently than cranking out the renders from scratch every time they adjust anything.

Are you using low-poly proxy character (and even environment) meshes while animating? That can help quite a bit in reducing on-screen overhead. Failing that, you can also try to take advantage of the Simplify panel in Scene Properties. Enable it and drop your subdivisions down to zero. When you do this, any object in your scene that’s using the subdivision surface modifier will have it’s subdivision essentially removed.

Thanks, I’ll give this a try, although will baking reduce memory when I’m not rendering? I’ll try and reduce the poly count and then baking high quality images and see how it goes.

Thanks Fweeb, I didn’t know there was a Simplify option. Will this still work if none of the objects in my scene are subdivided? Nonetheless, I will definitely give this a try… :slight_smile: