character flips upside down

Whenever i press p the character flips upside down and walks through walls when controls are pressed, its supposed to walk but not upside down and through walls.
Is this happening because I moved the armature?

It may have something to do with the orientation of your character’s axis. The Z axis should be facing upward, is it?

yeah the z axis is facing up but it always is, is there more than one axis?

Every object has a unique axis of its own which can be repositioned from the global axis. The two other axis directions are X and Y.

how can i reposition the objects axis?

First you should check that it’s even wrong. Select your object, press F7 to enter the Object buttons, then click the green Axis button to display your object’s axis.

Note that this is still just conjecture, I have no idea if this is your problem.

i uploaded a picture of the axis, is it supposed to look like this?

Attachments


Well, the Y axis appears to be backwards, but I don’t know if that would cause this problem. Could you isolate the character to a single blend and upload it so that someone could look at it?

:o I uploaded the wrong pic sorry about that,
the pic that i added before was for the body. Heres the axis for the armature and I can see the problem but dont know how to fix it.http://blenderartists.org/forum/images/attach/png.gif

Attachments


Do you have rigid body enabled…and…are you using dLoc…if so change it to linV or Force…

~Turin

I don’t have rigid body enabled but i was using dLoc because i didn’t want the character to keep moving after the the buttons were no longer being pressed. I tried to use linV and force but for some reason the character didn’t move. I would upload the blend file but i don’t want anyone to see the game until it is finished. Is there some way that I can reset the armatures axis?

It is very hard to tell the axis from the picture. Are you in front view? Side view?

You can delete the armature only, the first thing you added and then add a new one from top view.

Then just change the parent of the bones correctly.

Note that the armature has a different axis pointing up then a model object. An armature will have y pointing up when a modle object will have the z up.

And as was suggested by plantperson, upload a blend with the armature/model in it if you want more help as it is impossible to figure out from those pictures and your description.

You dont have to upload the ‘game’. Ok hope that helps.

I fixed it, I just loaded the backup blend that I made just in case and instead of moving the armature I just moved the ground. I was going to do this before but i thought something was wrong with the armature.