Character Model - Need help with node editor!

Hey everyone!

For the impatient: http://img.skitch.com/20100529-rc8jy23m2hqpp18jx936ceeax1.jpg

Haven’t been here in a while. Anyways, I’ll keep this short. I’m working on a character model, and I’m playing around with the node editor. I had the render deliver me an Emit pass and an Indirect pass.

In the node editor, these passes don’t appear to be available as an output. Check out this reference to see what I mean. For now I have been able to work around it by saving the Indirect pass as an image to my computer, then importing it back in.

Is there an easier way to do this, to access the two passes directly in the node editor?

Ernest

PS. Other constructive crits are encouraged as well! This is my first character model in a long time. I’m aware of a few problems with this WIP render, but feel free to voice your feedback if you got any!

PPS. I’ve looked around, and I’m still not entirely sure how Indirect Lighting works… objects with Emit values are supposed to provide light for Indirect Lighting, right? But from my tests, it seems that’s not the only thing that provides extra light… are there other factors I’m not aware of?

Hi - not sure EXACTLY what it is you’re driving at here but in your setup screengrab, I can notice that you’ve only got one input into the first mix node, which will produce weird results as it needs 2 (hence "mix).

Secondly, I would recommend checking in the world settings to see if you have environment lighting enabled, if you’re getting light from an unknown source. It might be that…

Hope some of that helps!

~P~

That is an awesome model! Very well done and I hope it gets figured out!

Hi,

Not sure if this will help but attached is a Blend file with a cube emitting light that indirectly lights a plane that it rest on.

Also in the blend is a node setup showing the node passes.

From memory there were older versions of Blender 2.5 that didn’t properly deliver the emit and indirect lighting passes. This was fixed in newer builds (which can be gotten from www.graphicall.org).

On your other points, indirect lighting currently only works when the Gather method is set to approximate. Indirect Lighting is light that is caused from objects that have an emit value. Environment lighting is from things like sky color, and the energy value from the Environment Light panel. Also Ambient Occlusion also can add light.

Attachments

IndirectandEmitPasses.blend (81 KB)

@praxedes: I was putting my character on a black background in the first mix. My newer setup now has an image that the character was mixed on. As far as environment lighting, it was most definitely off.

@BlendFace: Thanks! I hope I get it figured out too.

@terry_wallwork: I’ve got Indirect Lighting already working. But this is more of what I was hoping for: http://img.skitch.com/20100529-qhqdi3sg8krj4ajb2ar8dggetx.jpg

The reason I want this is because I’d like to blur the Indirect Lighting pass before it is applied to the image.

Also, something weird:

1)If I render my character with no Emit materials and no lights in the scene, the Indirect pass is blank as expected.

  1. If I add two lights to my scene and render (still not Emit materials in scene), the Indirect pass produces this: http://img.skitch.com/20100529-en3fk6exs9bapp1bswisfrp7hs.jpg

I Indirect Lighting only takes effect if there are materials with an Emit value in the scene?

same here i wanted indirect lightning in nodes but it just wont show up (it dies in render layer but in image editor
and when opening the blend posted here its called “radio” in nodes is only black
so im guessing the is not indirect in nodes yet
edit -------
downloaded latest blender from .graphicall.org and its working !