Character rotating

I got a super duper cube here, he moves using SERVO motion, and uses Rot: in the Simple Control box.
I move forwards, rotate, let go and he delays a bit before going straight, relative to the direction the Cube is facing.
And if I keep rotating while moving forwards, he acts like a car doing a burnout. It’s so gross, please help.

Here is the .blend to help you better understand the situation here:


Example 2.blend (464 KB)

Increase the friction either in the physics tab or on the material?


Servo motion simulates linear velocity on the three axis (axies?) separately.

This means you can disable a certain axis so as long as the actuator is active, the other axis are active. An example: disable z axis and as you move you ‘fly’ if you go off the edge (until you release the up key).

In the fixed blend I disabled the sideways y axis, which means only the forward (x) motion is considered. (I also disabled the z axis as this was not being used).

I have also added a second servo motion set to an inverted kepress. So if you are not pressing up the servo sets a speed goal of 0 (so instant stopping). I guess you could play with the value to make this less abrupt.

Hope it helps!


As always, any questions, fire away.


Try these settings on the second servo actuator, it gives a nice stopping action:

Remember, the max and min values are used to get to the target velocity value: so by setting -10 you tell the actuator to go from the first actuators speed (e.g. say 10) to zero by applying a maximum ‘reverse’ value of -10).


Example2 fixed.blend (372 KB)

Thanks Rubbernuke and Cam.dudes, the player is not gross anymore.