Chocofur Model Manager for Blender Released

Hey everyone!

After few years of developing both Chocofur main site and store I’ve finally reached a milestone which is releasing my first Blender Addon called - Chocofur Model Manager.

The addon is free to download and use for commercial, school and personal projects. It’s main purpose is to manage over 1000 models available through Chocofur, so the design and functionality are pretty straightforward. You can of course add your own assets to it and, in near future, create custom user categories. To learn how to use it simply follow this 8 min video tutorial:

Main features:

  • It’s free!
  • Created for Blender 2.79 (should support all versions down to 2.77)
  • Designed for quick and clean 3D model import.
  • Three model categories - Furniture, Accessories, Details + multiple subcategories.
  • Supports custom 3D models and assets
  • Includes Chocofur IES light files.​
  • Works flawlessly on Mac and Windows

​Current limitations:

  • Model’s library path limited to default Blender scripts folder (be sure to have enough space on your system drive!)
  • Pre-defined model categories which cannot be currently changed
  • Models are always added in the scene’s center point

I look forward to your feedback and really hope you’ll find the Addon useful. If there’s anyone who’d like to contribute in developing the missing features feel free contacting me :wink:

Best wishes to you all!

Tested, nice clear UI. Adding same objects to the scene adds more and more materials .001, .002 etc. Not so usefull.

Nice and useful.
Just made a quick try and I had an error most likely due to the fact that I’ve manually installed the addon on a portable daily build.
It cant find the scripts folder (it searches the script folder in a wrong path, not in the actual portable build’s path), it casts the error and it doesn’t give me the possibility to browse to the addon folder.
So I had to install models manually too. Not a big deal but… ya know…

Hey guys, thanks a lot for your feedback. I’ll definitely look for a duplicated material solution. As for the portable builds - this issue should also be fixed once I add the custom paths.

Thank you very much!!!

…this issue should also be fixed once I add the custom paths.

Looking forward the fix as there is a ‘path not found’ glitch here on Linux.

Great work and much appreciated…

You can customize the path for this (and any other application requiring strict path locale and naming), by using junctions in Windows. I believe in Ubuntu that would be symbolic links.
I brought the manager’s models out of appdata and into a synced cloud folder (Mega Cloud). This has double benefits for me:

  • It’s backed up automatically, in cloud
  • I can share it with my office colleagues and we can all expand the Libraries, at the same time, contributed by all and available to all

Here is how it’s done step by step under Windows (assuming you are UserName in drive C: ) :

  • After you have installed Chocofur and unzipped the free models and placed them in place.
    Check that the model manager works for you in this setup and save Blender’s User Preferences
    Quit Blender
  • Rename the Models folder (in scripts\addons\Chocofur_Model_Manager) to Models.bak
  • Create a folder where you want the models to be, in this example:
  • Open a command line window, with administrator privileges
  • Type the command
    mklink /J “C:\Users\UserName\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\Chocofur_Model_Manager\Models” c:\Users\UserName\Mega\BlenderModelsLibrary
    Check: if done correctly a Models folder with a shortcut like icon will appear under …\scripts\addons\Chocofur_Model_Manager.
  • Move the sub-folders from Models.bak to BlenderModelsLibrary folder under Mega folder and delete Models.bak folder (should be empty! be careful if not empty make sure all is in new location)

Done! Restart Blender

  • File locations may vary according to your disk setup, Blender version, etc
  • If it does not work for any reason, delete Models junction, create folder Models and move everything back into appdata, as originally

Thank you for sharing your Manager, Lechu
I hope the instructions above help people who may want to relocate the library, out of Appdata.

Looking through your free models I noticed that some blend files contain more than one object and all appear, at once, when I add from the library.

  • So all objects in the file will be appended?
  • Is there any limitation on how many?
  • Objects can of any type: curves, meshes etc. and can they have modifiers?

Kind regards,

Edit :
Quick testing showed all objects from source are appended, including lights, cameras, etc.
I can delete any objects not meant to be an asset, but things like lights and cameras help me whenever I review/edit this asset.
Does your algorithm append everything?
or can I keep them in original file and prevent them from migrating by hiding them, changing them to a hidden layer, or by any other way?

Hi @lechu! I am finally getting around to trying this following your video, but I am unable to get it to work on Win 2.82a, addon v1.2.1.

I followed your instructions diligently and I have the following folder structure:

  • library
    • vehicles
      • cars
        • maps
        • renders
        • blend files
    • furniture
      • books01
        • maps
        • renders
        • blend files
      • books02
        • maps
        • renders
        • blend files

and on and on and on

When I set the path to library/, I get nothing:

When I set the path to library/vehicles/, I get the following:

When I set the path to library/vehicles/cars, I get nothing:

Here is a snapshot of the folder, exactly as download from

What am I doing wrong here?

Hey Dimitar,

you need to set up your library structure the following way:

  • library
    • furniture (category)
      • chairs (sub-category)
        • maps
        • renders
        • blend files

Then it will work :slight_smile: btw you’re now using the most recent version of the Addon on which I plan recording completely new video tutorials in the upcoming days. It’s not that much different from the old one, we’ve added the ability of having multiple libraries instead just of one from Chocofur.

All the best!

Hi @lechu . I am having a lot of issues with Chocofur Model manager lately. I thought I had it fixed with removing a zip file that came with one of the sofa sets, but that did not seem to solve the issue for good. I am getting this error from time to time;

Running version 1.2.1 on blender 2.93.

The error comes sometimes if I enable another add-on or even disable another add-on. I tried on a clean unziped fresh “install” and even just going into preferances and restarting will either make it disapear or reapear. Haven’t been able to find a clear pattern to the error, but my guess is that it is somhow related to som registering or unregistering in/of the add-on that makes it behave strange.

On a side note, on my regular install I just installed the new substance plug-in, and then I get a similar error when going to the chocofur model manager from the preferances;

In that case the error shows as I click the dropdown in the preferances, and the model manager does not show in the N-panel at all. That add-on is in prerelease still so might be on there side for that one, but thought it could be related as it seems to be an issue with the 'library_collection" attribute …

Tried to e-mail you guys too, from the contact us on your website, but haven’t heard back so far.