Choppy Bone Movement in Pose Mode

I’ve been working on my first character and I’m currently working on rigging the bones. Somehow I must’ve accidently put in a command because now whenever I move bones in Pose mode, the movement is very rough and not smooth like before. Is there a way to turn this off?

The only idea that I have is the “Snap during Transform” option. When it’s enabled, your bones will snap to the grid. To turn this off, there is a small magnet at the bottom (right above the timeline), or a keyboard shortcut is Shift + Tab. Good luck!

Also disable subdivision surface modifiers while posing. Unless you’re using the new OpenSubdiv option, subdivisions get recalculated on the CPU for every little bit of movement.

I mentioned subdivisions, but any large modifier stack can slow down posing. Try to get as much as possible above the armature modifier. That probably won’t fully speed up posing. If not turn on Delay Refresh in the armature settings…


That will allow smooth posing of the rig, and only update the mesh once for each movement.