circle faces ? or what Am I doing wrong ???

My problem is that the faces are getting too dark, this seems to happen only with circle for some reason. I’ve done everything how she does it in the video, but still my version has over dark areas.

I’ve done the steps several times from 0:42-6:40 and always with same results. I just don’t understand what’s going on with blender at all :frowning:

I know I can either “flip normals” or recalculate inside or outside" that seems to get rid of those over dark faces, but I should not have to do this in the first place so what’s wrong with my blender ? I have also tested my version of blenderella on zipped version of blender which doesn’t need to be installed and still get the same results. I googled about this alot, but haven’t found any reasons for this behaviour. I have reference picture taken from the youtube blenderella video and my version of blender (screen shot not rendered) so you can see the problem here and as you can see it’s really hard to see all the lines and vertices because those over dark tones. I would like to my version also look as bright as the original on the blenderella video.

I have noticed when I have rotated the circle -90 instead of "+"90 degrees that then this doesn’t happen, but why is it then that she can use the “align to View” option when she rotate the circle 1st time becuase that way it will rotate "+"90 degrees and yet her version looks fine, but I get these over dark results in the lighting. Also when looking this behind it seems normal ??? “back ortho”

I use the lates version which is 2.71 (64-bit) and the blenderella video version is 2.5. don’t know bit.

Attachments


Select all the faces and recalculate their normals (Ctrl+N)

but how she doesn’t get my results in the video ? why I get theses backword faces ? Also I have noticed that if I add circle then Align to view so it’s not flat and then start to extrude and push vertices back and front it blender doesn’t make it look like that. So the only difference why it does when I follow the tutorial is that when I make the first eye vertices and move them back to make the 3D shape it then doesn’t understand what is back and what is front anymore ? Also in the 2.71 version I need to also select “inside” from the “pop up” window from the left to enable it to recalculate faces. It can be done from Shading / UVs tab also.

Okay seems I have maby figure this one out now. The rotation doesn’t seems to matter, but what seems to matter is do you extrude toward outside or inside and the shape doesn’t matter also so it doesn’t matter if you have already pushed some vertices to back like in my blenderella eye thingie. It all seems to depends on which way you start to extrude. From that point on blender seems to flip the faces inside or outside. I’m not sure of the corret term so to me inside is backwards and outside is frontside. so if you start extruding 1st toward inside than the faces are ok and then there is no need for flippin, but if you extrude toward outside the default is then that the faces are wrongway toward you when you view from front ortho like in my example so then you need to flip’em back where they came from! Not sure is this bug because in the blenderella tutorial she seems not to flip’em faces or just new feature or what, but that’s what I have now come to realise and wanted to share it because I have keep thingking this like 12 hours today when I first noticed this wierdness. Also if somebody else ever have this problem at least here is good explanation for them. Cheers.

I didn’t knew that it’s possible to add blender file I would have if I’ve knew that. I have already flipped the normals, but like I said this seems to be a problem only in the “circle” so I will do the steps again and give the blender file. Also after searching yesterday I found the face direction indicators “blue lines” so they were wrong way just to say that Im 100 % positive now :D, but yeah I make the blender file and check how I can add it or if you or somebody can tell me where to add it I had hard time to even add that 1 photo.

Sure. Check the tutorial that is linked in my signature. It has instructions on how to prepare a .blend file for upload and how to upload it here on BA or use an alternative site to host the file.

here’s the blender file. I have enabled normals face lines. Fronto ortho is the one I was making this from and back ortho is the “right” angle which it should be.

Attachments

Blenderella tutorial remake.blend (495 KB)

Everything seems to be in order. It does get the wrong side while extruding the circle but since there is no right side as the mesh goes, can’t blame it. Recalculate outside with more geometry and continue.

It did not matter how you extrude - it matters FROM WHERE you extrude out. Take this as granted - faster youļl be on modeling more often you will click Ctrl-N to recalculate normals.

Here’s an image and and here are steps to recreate:

  • Add default plane and subdivide it;
  • delete all but perimeter vertices;
  • select vertices and extrude Z - YOU JUST DID IT.

Another:

  • Add Plane, delete all vertices;
  • Ctrl-click around to get one loop for a face - one around both eyes, like infinity symbol in math;
  • Connect last gap by selecting 2 vertices and pressing F - YOU JUST DID IT.
    As soon as you try to extrude (well, Z again) you get it, one face normal has it’s own mind. And do not tell me that there is no way for any algorythm to calculate where is in, where out - the rest of the bunch of faces knows it.

Take default Cube, loopcut 2 loops from X and Y. Leave middle faces for, say, Duplication on faces and figure out what will happen on one from x axis and other from y. This is not about face normals any more, this is reality.

Ctrl-N every 3 minutes, Ctrl-A -> Scale, just to have peace of mind. Do not forget W - Remove doubles and increase Merge distance while you see that model starts to collapse; dial down a little.

Edit: Since last example was a bit more than 2 sentences - here goes blend. Somehow related to why there are messed up normals…

Often the inversion of the normals isn’t much of the user fault but is apparently how Blender works, a simple example of how to get inverted normals :

  • default Blender settings, delete default cube
  • Object mode add a plane and select it
  • go to Edit mode , if not already selected, select the whole plane
  • press E then type - 2 (with default setting it will extrude on the Z axis for 2 unit down)

The result is as expected a 2 units sided cube, but all the faces of that cube have their normals inverted even if you didn’t wanted that.

That’s just a simple example using only a single plane, in Blender there are tons of more or less complex user cases in which extruding a face will result in inverted normals and additionally i learned something new in the report about inverted normals problem , Campbell Barton mentionned :

Note, when you extrude, the flipping of faces depends on the direction you move the mouse

Making inverting face normal against your decisions even more easy during modelling.

So a very good idea when modelling in Blender is to regularly do a
-select all
-CTRL+N
To recalculate the normals and fix the inverted one that have been created during your modelling.

to me it seems to matter do I extrude toward inside or outside the problem just is why in the video she get it right and what am I doing wrong, because I don’t think I do anything wrong. I understand that when objects are getting really complicated and start having over 1000 faces there can be mix ups, but why in my case I get it wrong when I follow the steps on the video precise ? and have to use flip faces or recalculate ? that is the dilemma here to which I haven’t found any answers yet. i mean have blender designers changed this face thing from the version she uses on the video to new version 2.71 ?

Something that happened is that starting with Blender 2.63 , Bmesh has been replacing the old editmesh code, allowing many new tools, and additionally ngons support.
If the blenderella video you’re talking about is using a 2.5x version of Blender, it’s possible during that Bmesh incorporation, the normals calculation got screwed up a bit in Blender 2.63 and superior.

Additionally a normals calculation bug was fixed during the release candidate phase of Blender 2.71 :
https://developer.blender.org/rB728041019e8ee30a939a521c251d60e1f996a313
that fixes bug T40745
But if i look at the bugfixes list :
http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.71/Bug_Fixes
of the released Blender 2.71, T40745 is not listed as fixed, as they decided to stop the source code revision for the stable release the 16 june while the bugfix had been done the 22 june.
Meaning that “stable” Blender 2.71 is still affected by the normals bug i originally reported during the release candidate phase.

So download a buildbot version, that is current with the source code (and include the fix to T40745 ) and try to model the character in it, in case the problem you’re observing has been fixed by the bugfix that somehow didn’t made it in the now old 2.71 stable :
https://builder.blender.org/download/

It does not fix the problem from my simple “plane extrude” example, but the other bug with normals randomly set on extrude is fixed.

Do you think i’m doing anything wrong extruding vertices left over from subdivided plane borders? Or do i do something wrong by converting edge loop to curve and back which i extrude then? Iv’e got all possible face normals by doing this. And the code is changed and hopefully we will get some very useful things working again (Bsurfaces e.g).

Let’s face it - this is complicated and some things can be annoyingly stubborn to get corrected.
Ctrl-N it, meanwhile.

P.S. Btw, my examples come from recent Blender build and i’ve lost my bug-page pass again :(.

If you’re asking me, i replied in a previous post :

Often the inversion of the normals isn’t much of the user fault but is apparently how Blender works

And as long as it’s not considered a bug (read Campbell Barton’s reply in the end of the bug report) but it’s by design as he mentionned

when you extrude, the flipping of faces depends on the direction you move the mouse

We’ll still all be having inverted normals in our models, and we’ll have to still select all -> press CTRL+N often :frowning:

Okay guys I have cracked this thing 100 % from my experience. I downloaded and installed blender version 2.57.0 (r36147) I downloaded it from here: http://www.oldversion.com/windows/download/blender-2-57

the specific new version with the bug I have (looking from the splash screen like the older verion) is 2.71 Date: 2017-06-25 18:36 (Hash 9337574)

I have taken 1 screen shot from each version where I extruded circle with 12 vertices toward inside and outside 1 time that will show the normal direction. Left extrution is toward inside and right is toward outside and you can see that there is in fact a bug in the new version or blender!

I used “align to view” option which rotate the circle 90 degrees in x axes then applied extrusion. To me this is obvious now that there is a bug indeed in the newest version and it should be fixed because it makes you flip normals when there should be no need in the 1st place. I have also noticed that when I tried to extrude plane. Blender by default flips the outward extrusions wrong way also as you can see. I made excact same steps like in the circle. In older blender version it seems not to be possible to extrude all vertices of a plane so I didn’t do that. The plane extrusion is very annoying cos now I have to select the center faces separately or the program flips outside otherway and inside otherway them not going to same direction by default. That’s lame. I ahve provided the blend files too and that’s why I pasted the link where I got the version cos the older file don’t open in new one or maby it’s me because I have 2 versions now installed.

also I have to mention that when I checked out the normals on the older version they were all haywired in different positions some inside some outside al seemed randomly.

At least new version has all in the same direction although it’s wrong one still :smiley:

That being said what is the purpose of normals directions anyways ? If the wrong way is too dark and never used in any objects surface but directed toward inside an object ??

Attachments

face normals bug pic 2.71.blend (487 KB)face normals bug pic 2.57.blend (302 KB)


Your version of 2.71 is the “stable” one (and it’s 2014, not 2017 :wink: ) , so go try a buildbot from today as i suggested to see if the bug you’re observing has been fixed by the bugfix i was talking about (and that is not a part of the old “stable” 2.71) or if it’s “yet another normals bug” that you should then report to the tracker

Seems there was newest version in this month I test that and report back and yeah 2014 my typo :smiley:

Nope they haven’t fixe it.

Could somebody tell me what is the point of having darker side of faces anyways ? Has it something to do with coding these programs so they can emulate inside of an object ?

Every face has two sides because it has to geometrically, but by NOT computing visibility, lighting, color, material and texture for one of those sides (because it’s inside) a program can render twice as fast, right? You can enable double-sided in mesh properties to give up this rendering boost if you need both sides of a face to show.

Here’s something fun to try:

Add mesh: Plane.
Edit mode, select all, make four copies and arrange them around the original.

Select all, delete faces only, select all, F to make face. New faces points in the other direction than original!

Select all, delete faces only. Subdivide a different edge on each of the four copies. F again to make face. Now one face points in the original direction!

Selct all, delete faces only, select and dissolve those four added verts. Now select all and F to make face again. Now 2 faces are pointing in the original direction… !