Clamping kills the fire, fireflies

I’m blocking out a low light dusk render of a house reflecting into a pool. There is a skysphere with partial emission, and an array of IES lights and icosphere mesh lights. No caustics, filter glossy 1. The top render is with no clamping and looks good but I can’t get rid of the fireflies. That is 9999 samples. The bottom image is with clamping direct 1, indirect 5. It’s clean but the fire has been killed. Any ideas?

Well I wound up replacing the IES lights with larger icospheres with falloff. It’s not quite as nice, but I can get firefly free renders without clamping. So I guess it’s solved. I think cycles just can’t do low light with small but powerful lamps. I think it looks good enough to continue modeling.

I agree with your conclusion.

It definitely looks good. You could also powerup the lamps’ intensity and dim down the image later in comp.

Makes me wonder what might cause fireflies in the first place.
But if you want to increase light from lamps and not to blow it out on camera - use two Emission nodes mixed by Is Camera Ray from Light Path. One will shine for Camera, another give light to surroundings.

Hmmm… If I read that right, you said you have the direct clamp set lower than the indirect. If I’m not mistaken, usually you’d want that the other way 'round.

Don’t clamp your direct lighting, especially not at 1. It will kill any kind of post work you might want to do, and as you’ve seen, the general range of your image. Try turning off direct clamping and clamping indirect lighting at 1 or 2. Also, try turning filter glossy up substantially. I usually use a value of 10 without any noticeable side effects aside from reduced fireflies.

@trepanning - Thanks for the vote of confidence!
@Hadriscus - The lamps have increased strength in this version
@Eppo, thansk for making that mockup clone of the scene. I have included the packed blend, maybe you could take a look at it? Thanks again. I will experiemnt with the iscameraray mxing. That is a neat trick.
@pauljs75, I think you right, as m9105826 states. I have these two tests at 1200 samples each. The fireflies are all but gone, but so is a bit fo the “fire”
@m9105826 This version uses your recommendations. It works but I feel like the fire is still gone a bit.

I’m not very good with lamps in general, and usually use mesh lights. Maybe someone will see something obvious in the blend:
Blend on dropbox

And the latest test:

Are your lamps using the glass shader? That makes the bulbs count as indirect light when seen through the glass. Try this shader instead, it’s faster and will allow things behind it to be considered “direct” light. It’ll also put your lamps in the emit pass instead of mixing them into the transmission passes, which is handy. (it’s meant to be used with planar glass, aka no thickness. Thickness will make black regions show up, although they might not be noticeable in your render)

BTW, if you haven’t already, on your lamp glass objects, go over to the ray visibility rollout in the object tab and uncheck “shadow”, you’ll get an extra little performance boost.

Ok, very nice that shader of the glass bulbs works well. I have a solidify on them and it was enabled for the renders above, I disabled it for this one. I also disabled shadow in the ray visibility. I’d like to learn more about how those work with passes, etc… I usuallyonly use it to hide mesh lights from the camera. I can now get firefly free in 500. I’m going to do some more experiments. Thanks. This render is with indirect at .5, filter glossy 5. 500 samples.

It is the same thing I ran into trying to emulate a filament light bulb. Small emission surfaces expected to cover a large area are problematic in Cycles. Making the emitter surface larger does help out (as you display in post #2). I only clamp indirect and try to keep it in the 1.0-2.0 range. Any higher clamping seems to diminish the lighting.