Clear coat material doesn't get reflections from objects in Eevee

Notice how the grey material doesn’t reflect the water at all? Those tiny specks of white you see are actually from the HDRI backdrop, which is beneath the water, and that water material is not transparent in any way:

The grey material reflects just fine in the water, though (as well as the HDRI).

Does anyone know what’s going on here?

(EDIT: Oh, seems like an optimization made for the clear coat? Anyone know how to turn that off?)

Just a stab in the dark, but Material > Settings > Refraction Depth?

1 Like

Eevee makes a lot of sacrifices to physical accuracy in favor of speed. If you want physically accurate reflections/caustics use Cycles