Closing a mesh

Hi All,
Modelling a character’s basic mesh, using extrude to get my rough basic shapes (see pic., it’s a fin of a fish) but now I want to close this fin, and the Blender won’t allow me to do it!
I’m using FKEY (“Make face”) with all the different options, Auto, Make F-Gon, Skin Faces/Edge loops, with all edges of the ‘close’-end selected, but the command does nothing at all! Even tried selecting vertices instead but this produces the same (non-)result.
I must be missing something obvious, because otherwise it seems so difficult for the average user to create a simple mesh. Please can somebody please give me a pointer? What am I missing? Because I’ve seen many YouTube tutotials and they all seem to go on the extrude tool and they get a basic shape they want.
Any help appreciated.


Here’s one way.


You may have to post your blend file because your screenshot shows a confusing angle on the hole you are trying to fill. There are faces hidden by the angle of your screenshot, these are indicated by vertices whose white “tail” are indicating a face that they are part of that can’t be seen.

The make face option only works when 4 verts are selected.
Or two edges.
Skin works by selecting a parrarll line of verticies that aren’t connected.
That didn’t sound to clear…
. . . .

. . . .
So if you only lelected the dots above, and nothing on the sides then the skin option would work. And then you could use a loop cut (CTRL-R) and merge your new points to the gap you now have.

Yeah pretty much simply one way or another you have to close it with quad polys one at a time or in a row. Just depends on the situation. And a little tip. You don’t have to select 4 points. You can select two opposite edges and just hit f. It will make the polygon. For a row you can select the same number of edges on each side and f, then choose Skin Faces.

Dear Blender Friends,
First sorry for not answering, I was looking in my Outlook inbox for notifications of when you guys posted, but none came. I think maybe forgot to switch it on or something. Also been sorting out my hard-disk an been offline for the last couple of days. Sorry.
But hopefully this will help. I did a quick video to show you what I am trying to do exacatly, it’s in YouTube, only just uploaded so maybe not finishid processing yet. The link:
The video explain I found a work-around that kind of did what I wanted, but am not sure if this is the best way to do ‘Extrude’ modelling. I’ve seen lots YouTube tutorials that seem to use this technique, but never quite got how to do it. I was trying to avoid having hidden ‘inner’ faces by removing all the inner faces first but then found that my nicely extruded shape had a hole and there was nothing I could do to patch it.
I was just wondering if you guys knew a better way of doing this, as there are some great models done in Blender.
Look forward to hearing from you.
All the best,

Hi Paul,

Just to reduce your frustration somewhat. When extruding select your faces
then Extrude Region NOT Edge.

You can do this multiple times using S-scale R-rotate and G-grab to define
your fin. You can also S-scale in the Z-axis.

FYI Capitals = Keypress.

I have attached an example image.

Hope this helps?

Kindest Regards,



Hi pixeltwist,
Yes, it does help, it does help and a lot because I wasn’t sure what I was supposed to do. The only problem is what about those faces inside the shape you extrude? Say for example that image of the nice extrusion you did. Well, outside ok it’s nice and smooth, but if I go inside the mesh and take a peek around (or do a wire-frame view in Edit mode) I notice there are duplicate faces underneath the extruded shape. Not sure why, or maybe it’s that I done something wrong with the mesh itself but that is why I tried to extrude edges.

At least now that you’ve told me I know now what the ‘proper’ way to do it is. Certainly that’s the way I’ve seen tutorials do it in YouTube.

Happy New Year!! :smiley:

To the best of my knowledge about blender the auto make face option does not work for what you want to do. To properly fill in the open spot, you should create each individual faces separately. It is a lot more tedious than what you want to do, but if you want to get a clean mesh, you, unfortunately have to do a lot of the work manually.

Good Luck!


Hi Paul,

One thing to try when before doing your extrude.
In edit mode with all vertices selected click on
Rem Doubles in the Mesh Tools panel.
I think you may have duplicate faces caused by
a cancelled extrude this should remove them.

The model I created has no internal faces as you
can see from the bifurcated model attached.

If this does not help post your .blend and I can let
you know what the problem is.

Kindest Regards,



Hi Paul,

Any News?