Cloth Baking Stopped Working!

I’m very confused as to why cloth baking has suddenly stopped working for one of my animations :spin:
It used to work fine for that scene!
I saved the blend file to a new directory and pressed bake, it runs through the frames (you can see the counter on the screen) but nothing happens. The cloth stays as it was and there is no blendcache file created in the directory
I saved it back to its original directory and it still doesn’t bake
I created a new blend file and just appended the cloth object to it, saved it to the same directory as the first - pressed bake and it worked!
Any ideas?
I thought it might be vista read only permissions getting in the way (I have a dark blue check box on that folders properties that I can’t seem to get rid of) but why would the last file work if that was the case?

In the file where it doesn’t work, is Cloth enabled for display in the UI? That’s the button with a “+” in it in the Cloth panel and in the Modifiers stack. It has to be enabled for cloth baking to work. It’s on by default but it might have been disabled inadvertently?

I often forget to re-enable it when sculpting a cloth object – Sculpt doesn’t work well with Cloth enabled.

There are the two icons next to the “Cloth” button
-Enable cloth during rendering
-Enable Cloth during interactive Display
They are both highlighted - so I think thats ok!

Thanks for you quick reply

I copied the blend file to my home pc and still had the same problem - so I doubt its anything to do with file permissions

I made a new cloth object in the original file and that baked ok with the blendcache file being created

I still can’t get the orignal item to work

I think I’ll have to create a new one :no: - just wish I knew what had caused this!

Possible to post the .blend file to see if it works/doesn’t work on another’s machine?

I have found some bugs with cloth. If you have some settings you have customized in the cloth object you can write them down, remove the Cloth Modifier and add it again. I have had cloth just stop working properly or doing strange things and that seems to fix it.

Uploading a blend file - as mentioned - is the best way to really get to the bottom of it if it is something fixable.