Cloth doesn't follow pinned vertices?

http://www.youtube.com/watch?v=K0whbOU7H_U&feature=youtu.be So can somebody help with the cloth issues here? It doesn’t seem to be following the pinned vertices (at the waist), and I don’t know why :/. Also, is the clipping issue with the leg just to do with my collision settings, or is that something else too? Any help would be appreciated :3

EDIT: IGNORE THIS POST

  1. Are you sure you actually assigned the vertices to the vertex group? In edit mode with all vertices unselected, click ‘select’ in the vertex group, do you get properly selected. If not select them and click assign.
  2. Did you set the cloth to pinned, and choose the vertex group?
  3. Post your blend

Oops, I thought the link was to a tutorial. Ignore the previous post. The only thing I might offer is to try parenting the pants to the armature, just like the leg.

Ok, thanks, I think I solved it. Idk what was wrong with the vertices not following the rest, I redid the pinning and parented them to the armature (I’m pretty sure I did before, but maybe not :confused: ), and this time it worked, thanks XD. Also, I solved the clipping issue with the leg, I just had to increase the outer setting for softbody and cloth collision on the body model.