Cloth Sim Stopped Working


I am having issues with the close sim. I got it to work great.
Everything is perfect, but out of nowhere it just stopped functioning.
I tried clearning the cache and rebaking and nothing works. I don’t
get it. If I disable Cloth and then re-enable it, it works again. The
only problem with that is it just goes back the default preset settings.
I don’t want to have to start from scratch all over again ever time
this happens.

Has anyone else experienced this problem before? It’s happened to
me a hand full of times and it seems to be without reason, but maybe
I’m overlooking something.

If you know the solution I will hug you some day.

I too have experienced wacky softbody caching issues. I have not worked directly with cloth, but I think I know what you mean. I do a rewind, then find the folder on my heard drive where the cache is stored and delete the entire folder. Then I hit play again and it regenerates correctly.

This is for v2.46:

There are a number of reasons the Cloth sim may seem to stop working:

  1. Some action you took erased the data in the cloth cache folder. This can happen any number of ways, some of which may not seem to be connected to the Cloth object, like applying a Modifier to a collision object.

  2. You may have disabled the Cloth modifier for interactive display or rendering without actually removing it from the stack.

  3. You may have moved the Cloth object to a layer with no collision objects.

  4. You may have disabled collision for the objects you want the cloth to interact with.


  1. Check the contents of the cache folder if it stops working again. If the folder’s empty, the data was scragged somehow. It’s really too easy to do this, and is very annoying to have happen after waiting hours for a bake to finish. Start making a backup copy of the cache folder once a bake is done, just in case. This has saved my butt numerous times.

  2. The Cloth modifier (as with any Modifier, for that matter) can be disabled using the buttons in the stack, or the matching buttons in the Cloth sim panel. With these buttons “off” the sim doesn’t function, but is still ready to re-enable, all your specs preserved. You should not have to remove the modifier from the stack and add it back again just to do a new bake, which is what it sounds like you are doing.

  3. Make sure your Cloth object and its collision meshes share at least one layer.

  4. Check the settings for the collision objects as well as the cloth object

Everything listed, I have already taken into consideration.
Everything looks good.
Everything is on layer one.
It is visible in the interactive display and render.
It is enabled.
Collision is still set up the way it was when it was working.

I just don’t know. When I bake the cloth sim it makes
new files in the cache but it doesn’t actually do anything.
The files are of it standing still and not acting like cloth.

It works completely fine again if I disable it and then
start over with a fresh cloth sim setup, but if I have to
do this everytime it’s just a little more work I need
to do.

Is there a way to save your own settings as presets?
That might help so I don’t have to slowly enter all
the numbers one by one to get it acting the way I
need to act each time.

This same thing happened on one of my other characters
too. The cloth sim worked great for a while and then it
just would no function anymore.

The things I am doing that I am suspicious might have effected
it some how are these:

-I have been saving new versions of the blend file as I progress and
make changes to the model.

-I have everything added to a group so I can import it into the scene
all at once. (but I am working on the actual character’s blend file, which
is its original location).

And since every time I’ve baked it, it seems to make a new cache folder,
I’ve been deleting the old ones.

at this point I guess (if I can’t save my own cloth settings) I might just
have to pick whatever preset acts closest to what I need so I can
reload disable and re-enable it every time this happens. It stinks for
my other character thought because it has to be more stiff of settings
so this won’t do…but for that one I should probably use softbody instead.

This is likely the problem – not really yours, though, it’s just a slight design flaw in the way the cache folder works.

The cache folder is named in a fashion that correlates to the .blend file from which the data was baked.

So if you change the file name by saving it to a new version, the sim starts looking for a different cache folder. Since it can’t find one, the sim doesn’t work, and you have to bake a new one.

Or, you can rename the cache folder to match the new filename:


with * being your new .blend’s filename, no extender.

Try this and see if it fixes the problem.

Would that make sense if re baking it still does not work?
unless the re bakings are still trying to save the new caches
to the old folder. I’m experiment with that and see.
Thanks for the tips.

Edit: I just checked the file I’ve been trying rebake and
get working. The cache fold does already have the same
name of the blend file I am in. So maybe this is really
a glitch in Blender. I’ve also tried changing the settings around
and rebaking with no results. The only thing that has
worked so far is deleting it all and starting over.

Also, I don’t know that it would have to do with saving
newer versions since I’ve been rebaking everything each
time. It stopped working around the 6th or 7th version.
It wasn’t right away either. It was after saving the file
and gong back in a different day to start working on it
again. It just didn’t work anymore.

So far no solution to this problem. Only work-arounds.

Are you using 2.46 or 2.47? My experience is only with 2.46, so there may be some difference, I haven’t looked into 2.47 yet.

Something to try, though – next time you have a sim baked to your cache folder, make a backup copy of it in some safe place. If the sim stops working again, save the file (a different name is OK in this case).

Open a new .blend (Ctrl+X). Append from the file that stopped working the Object that is your cloth mesh. Make sure it’s present in this new file, then save it under a different name. Close Blender. Rename the backup copy of the cache file to match the newly-created file that has only your cloth mesh in it, and put the renamed cache folder in the same folder as the new .blend file.

Open this new file in Blender and try the cloth sim. It should work (I’ve done this trick quite a few times). If not, consider submitting the new file and its cache folder with a bugreport.

I’m using 2.47

That sounds fail proof.

I will try that out once I start animating. For now I might just have to
start from scratch again since all of my previous bakes were only for
testing as I tweaked it to move the way I wanted. So I haven’t actually
animated the characters yet for the real bake sale.

Thanks for the baking wisdom.