Cloth simulation: Blender 2.83 freezes

Hi,

right now, I’m trying to make a cloth simuation after a very good tutorial that has been made with Blender 2.68a. I’m using 2.83, and in the beginning I could adapt the workflow, but when it came to adjusting the parameter settings for physics, all-of-a-sudden Blender got very, very slow. In addition, I couldn’t find the cloth pref ‘cotton’. When I wanted to play the simulation, Blender froze. I had to restart my PC (Ubuntu Mate 20.04). The same happened with Blender 2.82. When I tried to render the animation via shell blender -b cloth.blend -E CYCLES -s 1 -e 250 -t 2 -a, only the very first frame was rendered; then Blender was killed. Hardware used: AMD Ryzen 3 3200G with Radeon Vega Graphics × 4, GeForce GT 710/PCIe/SSE2, 16 GB RAM. Does anyone have an idea where the problem could be?

TIA,

Claus

P. S.: The link to the .blend file (6.3 MB).

Hey there,

You’re problems have nothing to do with the hardware, but the geometry in the file:

  1. Each simulation mesh should have its scale reset to 1.0 ( CTRL-A -> Scale)

  2. Your cloth had over 30,000 ( 30 thousand ) excess faces. In edit mode select the entire thing and then use vertex->merge-by-distance. ( default values).

  3. The cloth Modifier should be at the top of the modifier stack. Then Solidify below that , then Sub-D at the bottom.

  4. The cloth doesn’t need a Collision modifier.

  5. Meanwhile, the presets are here:

image

  1. Set the collisions to have a distance of about 2mm ( 0.002m ):

image

also do this on the collison distance for the bowl and ground plane.

  1. On the cloth - set Quality Steps to a higher value, say 20:

image

It should now behave :slight_smile:

If you still have problems delete all the modifiers, and re-apply them, but the the biggest issue is the huge number of faces in the cloth mesh.

Cheers,
Dj

Hi,

many thanks. I will try what you suggested. Big relief that it isn’t due to the hardware. :wink:

Claus

P. S.: I couldn’t find vertex->merge-by-distance; only mesh > merge > by distance.

Mesh->merge->By Distance… that’s the one :slight_smile:

Thanks! :wink: Because Blender still freezes when I go to edit mode, I decided to redo the animation from scratch. This went well until I subdivided the cloth (plane). When in edit mode, the cloth is visible, but when I switch to object mode, it disappears. :frowning: In the scene collection, it is still present, but not in the scene. I am adding a link to the .blend scene.

Claus

-> cloth_02.blend

Hey,

The object only seems to have vanished because you have your timeline at frame 96, so the mesh has dropped out of frame -

Other than that, it works fine - though you still have to put a collision modifier on the Plane floor and bowl. It’s just the cloth object that doesn’t need a collision modifier.

This is the sim I did:

Here’s the .Blend:
cloth_03.blend (866.4 KB)

CHeers,
Dj

Thanks!

Claus

P. S.: When I click on the ‘cotton’ pref, nothing happens. Is this normal? And after I apply the subsurf modifier, it is no longer visible in the ‘modifier’ menu.

P. P. S.: Now it works! :wink: