Cloth simulation completely freezing sometimes since 3.5

Yesterday I opened a file and couldn’t simulate a vest on a character, blender just froze permanently. After importing the same character, with the same pose in a new file it worked like a charm. Today I am having the same issue on this new file. I’ve never had this issue before 3.5 since I opened the same file in 3.4 yesterday and had no trouble.

Initially I thought this was due to self collision distance being larger than the vertex distance of the cloth, but once this happens even one time, the whole blend file will never simulate that object again. I even restarted my PC and it still won’t do it, even on an older save somehow.

I’m as sure as I can be that this isn’t some issue on my end, doing something stupid like subdividing it like crazy, I checked simplify on, at 0 subidvisions and I made no change whatsoever since the last bake except turning simplify on and off, and I think but I’m not sure that I tried to bake it with simplify on accidentally, which is where I think it broke. For reference it used to bake 120 frames in about 5 seconds, now I waited 5 minutes for 1 frame before I gave up.

I completely replaced the object with the original one, made sure everything is ok and blender still freezes. It didn’t freeze when simulating a brand new plane object tho. I dunno what to make of this, just need a solution that doesn’t involve importing everything for an issue I can’t understand.

I’ve had this happen so far on 2 entirely different meshes from 2 entirely different projects that I wanted to simulate. Simulation itself is hard enough without having to deal with this.

Edit: same file bakes perfectly in 3.4, I just tested it. The only issue is it clips with the body eventually but that’s way after 1 frame.

I also just disabled all collision objects and it still won’t bake…