Cloth simulation is "eating" itself and going inside the main object

Hello there.
I have some troubles and an issue with a cloth simulation. When I baking the simulation and start playing it on timeline, clothing (pants) on a left leg of a character is messing up and going inside mesh. On 15th frame it doing same thing on a thigh and on a knee.
First I tried to scale character and pants (scaled by 3 points) and made another bake. The result was same, as before.

Than I thought about the geometry, so I added subdivision surface modifier to mesh, but it did not helped too.

Next to it, I checked character’s and clothing normals, but they also look outside of meshes.

The last and a very important thing is collision, so I added quality steps and reduced the distance (same on the character). Unfortunately, It didn’t help and the result was pretty mush same.
Characters collision settings:

Clothing collision settings:
Modifiers on the clothing:

I also attach a link to file on the google drive (cause of packed materials, even with removed PS (Particle System).
Also about the scene itself:

What am I doing wrong? I would appreciate any help.

Sorry for the dumb question, but aren’t you supposed to pump up the distance instead of lowering it?
Also the outer thickness should be pumped up I think.
Sometimes it helps giving more edge loops to the knee part of the pants for smoother deformation.
Unfortunately I’m from the phone so I can’t check it myself, and I don’t use that many clothes so I can’t help you that much :()

Nice looking pants :slight_smile:
Good luck :slight_smile:

Hello. Thank you for your reply. I will try it out.

1 Like

I tried different distance (from 0.001 to 0.1 and 0.2), still simulation is eating itself, but I realized one of the problems - collisions on boots, they are making left leg going insane. Also, a top going weird because of pinned groups (dunno why, but still its a fact). The only thing that I still don’t understand is a knee issue (cloth on knee going inside mesh even with added before geometry).

I found a solution and its quite strange. I watched a video, where cloth sim was explained and it “killed me”… The problem was in mesh size - it was too small, even scaled by 3, so I tried now 20 times - and it worked better. Than, changed distance a bit, made bigger stiffness and removed collision from boots. And it worked:

Also, I removed Armature modifier and just used surface deform to pin top to mesh.
Thank you all for help)

The video with explanation:

With boots is a normal problem, so I will fix it soon :slight_smile:

1 Like