Cloth Simulation: Random jittering to bake after reopening blender

I have this cloth simulation in Blender and every time I initially bake it, it looks fine. However, If I close and reopen Blender, it has this horrible jitter to it, almost as if it has some kind of displace modifier (it doesn’t, I checked). Any clue what could be causing this? The only force in the scene is wind.

Here’s a comparison:
Good


Bad

Bake the cache to disk so it doesn’t recalculate

1 Like

If I do that, when I reopen the project, it acts as if it never got baked. It says all of the frames are on disk but it won’t render or display them.

That’s… weird :thinking: Is your disk cache on an internal drive or an external drive?

External, I’ll try saving it to an internal and see if that’s any better

1 Like

Still no luck, baked it on my C drive and it still becomes a jittery mess. This is such a bizarre issue LOL

If anyone in the future comes across this, I “solved” the issue by not having my simulation start in the negatives. It’s not really a proper fix, but I was motion-tracking footage and just trimmed a few frames off the beginning.

1 Like

Oooh yeah negative frames don’t work for simulations. I forgot about that

Thank you, I don’t think I would have figured this out. For a while I’ve been wondering why sometimes when I load a saved Blend file with existing physics (disk cache), I have to rebake everything. Like there are no physics at all, until I rebake. I just tested and yep it’s any file where I used negative frames to ‘settle’ the physics before the animation started. Good find.

1 Like