Cloth Simulation works very strange


(alive-one) #1

Hello. I’m trying to make simple curtains. But, after several hours of trying, I am still at the very begining.
When i play animation or try to bake it, i see that cloth modifier does not afect mesh as it supposed to (Cloth_Sim_Problem01.jpg), or ruin geometry, like, i don’t know. a godzilla. (Cloth_im_Problem02.jpg)
I attach screenshots and *.blend file. You’re my only hope ©


cloth_sim_problem.blend (2.6 MB)

P.S. I used GPU (GTX 1060 6gb) and CPU (Xeon E5450) rendering but effect is the same.


(omgold) #2

Three issues:

  • Your mesh is not fine enough.
  • It is not a good idea to instantaneously set the final shape key. The sim likes smooth changes.
  • putting all vertices in a plane, including clothpins doesn’t give the curtain a ‘seed’ to start wrinkling, so it will delay doing that undesirably. I changed that only for the left side, so you can see the difference.

Fixed version:

cloth_sim_problem.blend (948.4 KB)

In addition maybe you want to use more clothpins to prevent the artifacts there.


(alive-one) #3

Thanks for your help, but i actualy see no difference. Both curtains looks weird as they looked before. When i try to play animation and slightly move the key curtains looks like at my first picture. When i try to bake, they looks like at second picture.


(omgold) #4

Ehm, what do you mean by slightly moving the key?

Tried again on a different system. When playing animation on the file (as is) it works perfectly fine to me.


(alive-one) #5

Like in this tutorial. https://www.youtube.com/watch?v=IKwXyPK8VbQ I start animation, then slightly, with my mouse pressed and hold, drag Key1:Value to slowly change value from 0 to 0.5 and further. For the first time it worked for me, but now it does not.


(omgold) #6

Why not keyframe it instead (as I did in my blend)? That way it is reproducible.


(alive-one) #7

I look through your file once more. May be i lost something. But how i can keyframe an animation which never play properly.


It seems that blender or my pc is out of computing power. May be 8Gb DDRII is bottleneck.


(omgold) #8

Uh. No, that is not like it looks for me.

Can someone else please try it, too?

About memory, hmm, 8 GB is not plenty, but for such a simply example it should be more than sufficient. I did the testing and tweaking on my laptop, which also has only 8 GB.


(Pixelfox) #9

Your fixed version looks excellent here in 2.80 beta.

I’m also running on a 6GB 1060 as the OP is. Nothing about this should care about your video card as far as I can think of. The simulation requires only 300MB or system memory for Blender and basically zero GPU resources.