Cloth Simulations on OS X / iMac

I have been having some issues with cloth simulations in 2.9 on my iMac. I mention iMac because it almost seems like its a graphics related issue or something, Radeon Pro Vega 48 8 GB., 128MB system ram, 3.6 8-core intel.

I followed about 10 tutorials doing basically the same thing, a sphere with a plane. I make the sphere the collision item, the plane the cloth item. I enable self collisions on the plane, I have tried subdividing the surface in edit mode, but also applying a subdivision modifier before the cloth modifier. I tried baking, previewing, numerous things, no go.

Is there some limitation with cloth simulations on this setup? I am not sure why the plane just does nothing, press play there is no cloth simulation, nothing happens. Maybe I am missing something in my setup, but I cannot figure it out.

Any ideas?

Few images of the setup:

Don’t you have to bake the simulation before you play it?

Yes, even when baked the plane does nothing, does not move.