Clothes don´t appear in rendering

I am studying clothes in Blender. I created a nice flag animation, used the pinning points, baked it and everything works fine. However, when I render it, the flag simply renders as a normal plane, i.e.: it is rendered as if no cloth has been applied (a stiff plane).

  • The animation is OK, since ALT+A shows the flag as it should be.
  • Both “Enable Cloth during interactive display” and “Enable cloth during rendering” are activated.

Any tips?

Hi Leandro;

Did you push the button Anim instead of Render ? If you simple press Render you will get a still image.

[]'s,

Still

Yes, I did. It´s not a matter of only rendering the first frame. If I render the animation or a further frame (in which the flag is cloth-deformed as it should be), it still renders as a still image. :frowning:

[EDIT]

Weird! I used a render preview window over the deformed flag. The flag looks deformed in interactive display, but the preview window over it shows it as a normal plane. :confused:

Dunno. I simply close the rendering preview and opened it later. Now it renders properly. Since I am sure that I did not click anything else, I suspect a bug (Blender 2.48a).

[EDIT] BTW, I also used subsufaces in it. Does the order of modifiers mess with that?

Thanks for the response anyway, Still. :

Oh, and another thing. Does motion blur works with clothes?

Its the subsurf modifier, it must be below the cloth modifier