Clouds Texture in BGE? Help :)

Hi guys

I cant seem to show cloud textures over UV maps in the BGE - i have a clouds texture on and it shows itself “the default purple” in the material box but i hit play and nothing…

ive heard it cant be done… is there a work around, other than changing the texture im using for the uv’d object

You can bake it into texture:

  1. Duplicate your object.
  2. Create a new (blank) texture in blender uv/ image editor.
  3. Select your original mesh, enter edit mode, and then in uv/ image editor choose your new blank texture.
  4. Under render panel, change the render mode to “Textures”
  5. Activate “Selected to Active”
  6. In object mode, select your duplicated mesh, and then shift- select your original mesh.
  7. Hit “Bake”.

Thanks ill try now :smiley:

this is the effect i get :stuck_out_tongue:


How could i improve the result?

maybe if i did like a bump map?

what result? u got the clouds on the plane u wanted? so thats done.
what result u want?

i mean now i want to put bump, do i do the same thing, but with geo instead?

Under Texture panel, you can enable the “Normal”. Make sure there is a light in your scene, and you’re in GLSL shading mode.
Btw, that chess-like red and white color is an additional texture, right? Not a result from baking the cloud texture?

u can bump it in a few ways, with a normal map (the purple/blue thingy) or use a black/white map.

the black/white map can be done in a few seconds, select your object go to edit mode, open uv window, u got the image there with the clouds yes? save that image as image. then open it with a editor and make the clouds black/white, save as… and then just ad a new texture on the plane with the new picture. scroll down and turn on normal, expiriment with the settings to get the result u want.

if this is what u mean

ill try that

its GLSL and the red/white tile with the clouds on it is 1 texture.

Ill try that too

its GLSL and the red/white tile with the clouds on it is 1 texture.

Ill try that too

Then the best thing to do is start over again. this time before u bake the clouds to your target, make sure u make a new image in the uv window. this way u create 2 textures. else if u use a bump map it will bump all of it instead of the clouds only.

I did have it on a new image though, but cos i selected the orig mesh - which had the tile texture and the cloud - it baked it to one o.O

Well, if you don’t want that tile texture appear, then remove it first from the original mesh, and like like cotax said, rebake to get the clouds only :slight_smile:

ok now it just seems to bake it to that texture even if i remove it o.O

EDIT:
Actually, i got it just how i wanted :3 fixed it

thanks guys :slight_smile: works good now! :smiley:

This is the effect now :smiley: Just how it i wanted it