Cmake -- Codeblocks -- Windows -- error


It took me weeks to start this new thread, as there was always these subconscious questions of did I try everything, is there something else I can do, is there another place to check, is there more documentation I did not read, maybe I’ll “Google” it yet again, but now, I formerly give up and will post here (knowing I exhaustively searched any resource) …

I am on windows XP pro, 32bits machine, installed Codeblocks (including the MinGW assembly) and C-make, downloaded the svn-tortoise and all the blender source (including the windows libraries), I then open Cmake GUI (but I also tried the command line) and try to create a code-blocks project , it generates following error, over and over and over and over … no matter what settings, no matter what params, no matter what state I am in!


The list of things I tried to solve it is quite long, including:

  • setting system paths
  • un-installing, reinstalling
  • command line
  • tried the solve different code trees, sfml (youtube)
  • read and re-read manuals
  • asked friends
  • cried
  • shouted
  • banged my head and computer
  • stuck my head in the sand and pretended the error wasn’t there, to come back to it couple of weeks later to find out it still was
  • asked the blender artists

I now officially need external help.

Anyone out there has a clue on what is going wrong or maybe knows that one thing I did not try?




Know this reply isnt much good but suggest not to use code::blocks, I tried using 2-3 times on linux and never managed to get it running successfully/well (couldnt get debugging to work, also recall it had other glitches).

suggest QtCreator/Netbeans/Eclipse on win32, or use msvc2008

— edit —
Is mingw’s BIN directory in your PATH ? (perhaps thats why make cant be found)

— edit —
First - did you manage to get mingw-make / cmake working? (without any IDE?)

do you mean: “did you try using the command line?” yes I did, same error.

basically I am trying to build a solution(read project) for code-blocks so I can browse the source, make some changes (like your video tut regarding select inverse for latices) and compile. But C-make won’t even let me build, so it is C-make’s problem for sure …

I have this strange hung that there is indeed a simple parameter not set for C-Make, but my paths are set correctly as are all the other params I can think of, so it must be something else.

Anyway, possible solution is going to QT-Creator, could you list the advantages and specially the disadvantages for this GUI for me, please?


and regards



ok. so best ignore IDE’s for a bit, I managed to get mingw/cmake on XP working without any troubles.

Did you follow these instructions?

perhaps we miss some troubleshooting issue which should be documented

  • When installing Mingw did you add it to the path (IIRC this is an option)?

  • What version of Mingw are you using?

  • Did you install to the default location or choose a custom mingw path (perhaps this is why CMake cant find it).

  • Can you manually point CMAKE_MAKE_PROGRAM to your mingw32-make.exe (should be located on your hard disk if you installed mingw).

As for IDE’s - I tested kdevelop/anjuta/netbeans/eclipse/code::blocks/code-lite - and found qtcreator best so far, of course your mileage may vary, main problems with others are very slow at at parsing blenders source code (assume many devs dont use them with millions of lines of code) and general stability of some isnt too good either, the feature sets of all are basically ok.

hey ideasman42,

your suggestions are very useful but mean I will have to change my mindset from IDE to command line usage (read: go from windows to linux), and that is difficult for a prick like me who was born and breast fed windows for every single computer thought developed. Basically trying to say, it will be some time before I have gone through all your advices and tried them all, but I (we) will get there in the end …

I just wished the solution would have been more simple, but that is just life aint it

thanks already for your time and energy


Hey hewi.

I have Windows 7 64 bit. I ideasman42

in that case you might be best to use MSVC2008.

Hey hewi.

I have Windows 7 64 bit. So far I have only been building using VS 2008 Express, but I went ahead and tried to generate build files with CMake for Code:Blocks and the MinGW Compiler; I’ve detailed the process a bit down below. Also I think ideasman42’s suggestions (post #4) for generating build files with CMake for Code::Blocks were the resolution to the CMake error presented in the image in your first post.

Steps to create Code::Blocks - MinGW build files for Blender on Windows XP using CMake 2.8.7
1) Set your Source code directory, and your binary build output directory.
2) You - may - need to delete any files generated by CMake within the binary build directory if there was a prior error.
3) After pressing “Configure” a dialogue will appear. Select “CodeBlocks - MinGW Makefiles” for the generator.
4) CMake needs to know where your compilers are located, so I know of at least 2 possible ways to inform CMake.
[INDENT][INDENT]a) If you select “Use default native compilers” check to see if the MinGW’s compiler directory (mentioned below) is listed within XP’s environment variables. If it is not listed then add the directory path to Windows XP’s System(“Path”) - or - User(“PATH”)environment variable(NOTE: separate directories with a semicolon). Press “Finish”.
[/INDENT][/INDENT][INDENT][INDENT]b) If you select “Specify native compilers” press “Next”.

Then you have to specify the compilers you will be using. I’m guessing that you would use the “mingw32-gcc.exe” (or possibly the gcc.exe) for C compilation and “mingw32-g++.exe” (or possibly g++.exe) for C++ compilation. These compilers can be found within the “\CodeBlocks\MinGW\bin” directory (if MinGW was bundled with C::B download), and - I think - “\MinGW\bin” (if you installed MinGW separately).There are a number of compilers located within these directories, but I’m not very sure what the difference is between any of them.
IF - item 4) b) above is true.
5) After pressing “Next” you will then be greeted by an error message. Press “OK”.
6) Then make sure to enable/check the “Advanced” option within the CMake gui.
7) Then find the CMAKE_MAKE_PROGRAM option within CMake and click on it.
8) An ellipsis should appear on the far right. Click on it.
9) Then find and select “mingw32-make.exe” for your make program. It should be in one of the exact same directories I listed above.

10) Then press and run “Configure” twice ( I’m not sure a second time is necessary).
11) Then press generate.


You can then go to your build directory and Code::Blocks project file(.cbp) should now be located there. Open it up. Build!!!:eyebrowlift::evilgrin:

Good day to you sir.

Hello hewi, it’s me again.

I’m sorry to bother you again sir; I had an idea that may or may not work - I have no idea. If you haven’t yet generated your build files and what-not through CMake for Code::Blocks(of course, I would imagine you would already have turned to VS 2008 by now) - and - you are still interested in doing so, what I could possibly do would be generate the build files, libraries, and folder structure, etc… for you and email the ENTIRE folder structure and it’s contents to you.

The folder structure is about 16 megs.

Well if your interested let me know, and maybe something can be worked out. Whatever the case, sir, I wish you the best.

Good day.:slight_smile:

As original error message in picture attached, it had to do with my MinGW32 installation. I deleted all files, all trees and applications, started all over and, after a couple of minor errors and hacks, managed to compile. Main source of information:

Thanks all for the energy