codec frustration

I’m pulling my hair out with this… been working on a project involving animation… I’ve run into frustration involving codecs… thought I figured out a solution but it seems to be a cross platform issue.

PROBLEM:
I’ve rendered out frames for an animation as .png. They look how I want them to. However, if I compress them with any codec (preferably divX low motion) the .avi comes out MUCH darker than originally intended.

I thought I could just lighten up all the frames to compensate for this… However, it seems to be a cross platform issue… If I upload the original .avi to youtube it displays correctly. And if I open it up in an editor like virtualDub it displays correctly. However, If i play it in windows media player, or VLC, it displays dark.

Here is a link to the uploaded youtube video (displays correctly):

Here is a link to the original .avi before upload (displays too dark):
http://studentweb.eku.edu/mark_ballenger/buddies_test3.avi

I have not tested the original .avi on any other pc besides my own. Maybe it will turn out differently for you.

This has proven to be a difficult thing to research. But my buddy in film tells me that he’s run into this as well, yet doesn’t know of a solution. Any help is truly greatly appreciated.

Thanks in advance

Seems ok to me…

Oops… I’ve linked the wrong .avi… Gimme about 10 minutes and I’ll have that fixed.

Okay, fixed… the original link has been changed to point to the right file now

Hello, I had similar problems as your when I download yr AVI I managed to solve the problem on my PC. Here is the link to similar problem https://trac.videolan.org/vlc/ticket/962 Set your video rendering engine to OpenGL. Any other settings like “DirectX video output” and “Windows GDI video output” works fine. Here is the solution. 1. Open VLC media player. 2. Click on Settings and select Preferences… . 3. Expand Video and click on Output modules. Note that DON’T expand Output modules, just click on it. 4. Check Advanced options in the lower right corner. 5. Set Video output module to either “DirectX“, “OpenGL” or “Windows GDI“

Sorry, I cut and paste from my bible, I don’t remember which link that solution came by (somewhere early Jan 07). The author is AMIDA168 from his/her blog. I am positive it should work on yr PC now.

Bluewhale:
Thanks, That does play the video correctly. However with those settings, other particular videos play with an odd hue adjustment (reds turn blue, etc.) I find it odd that it odd that certain videos turn funky with these settings and others play correctly.

Anyway, it’d be nice to find a solution that doesn’t involve tweaking some sort of media player just to view this video… Being that my main concern is that I need the video to look how it is supposed to look as soon as a viewer opens it after downloading… Ontop of that, my main audience will probably be using windows media player anyway. So I kinda need a way for it to work on both.

Thanks for the post though

i use AVI XviD - it plays in WMP and the rich content (Explorer window).

hm, thnx for the input papasmurf… But I seem to get the same results with the Xvid mpeg-4 codec: it is also too dark :frowning:

I am unable to dig further than that for one thing codec comes in different flavour over the years. I normally satisfy to what ever looks nice on Win Media Player (that is about 80% world wide computers using it). This is just the beginning of media production problem wait when you deal with TV and cinematic casting that will be another story all together.

You’d figure PC media developers somewhere would have resolved this issue. It seems like its mostly a PC issue. My friends mac plays the .avi video just fine through quicktime. Further why does youtube playback the video properly??

So now, if I compensate for WMP, I alienate the entire mac audience? Not to mention that the youtube video will be too bright. There has to be some kind of better solution to this. If not someone seriously needs to find it.

I understand that cross platform issues are complicated, but hell, is it too much to ask for something to work the way it is supposed to? >_< If I paint red paint on a canvas… I expect to see red paint damnit.

Ugh, sorry now I’m just ranting. But as an artist, this is very frustrating. It’d be different if there was a way to resolve this, but it seems like no matter what, you have to sacrafice something :frowning: kinda throws a monkey wrench in the creative process.

Thanks all for you help.

Yes, as an artist we should be fussy with graphics properties. Could you post your second AVI (wrong colors) let me try, no promise b’coz i’ve my own project going on.

not xvid mpeg-4. Avi XVid. mpeg4 dont work 4 me.

Could a normal human who can speak plainly about this please add a wiki section to Output Formats, please. We need a separate FFMPEG paragraph (or two) about what works and when, and what to do when it doesnt? thanks.

Attachments


I see, I’m sorry I didn’t read thoroughly. But I’m guessing you’re using some CVS build? I only am using 2.43 :frowning: I don’t seem to have those options on the rendersettings window. Just a format tab. And Xvid AVI isn’t an option for codecs.

Is there anyway to use that codec without installing a new blender? I’m kinda in the middle of a project here…

Super Converter is the compressor that I use it may work for what you doing it may not.
(Super Converter is freeware)
I will upload this in a minute hopefully.:RocknRoll:

Here it is.

sorry I didn’t get it up made a mistake i’ll post it tomorrow

http://www.erightsoft.com/SUPER.html

Is this what you were talking about? Looks like great software. But I’m not looking to convert anything. Though I could try to export to some codec from blender, and then try PapaSmurf’s suggestion of trying the Xvid AVI codec… But I would assume a lot of unwanted artifacts would be present from compressing twice… If I get time I’ll try that and post the results I guess.

Hope it works.

well, i’ll cut ya a deal and offer you a free upgrade to 2.44, which is what the screenshot is from and we’ll turn that :frowning: into :slight_smile: