COLLADA export broken in 2.46...

or is it just me?
COLLADA export (both versions) worked fine for me in 2.46RC3, but I get:

TypeError: cannot concatenate ‘str’ and ‘DaeSampler’ objects

I tried the official build as well as an optimized one from graphicall.org

I was having problems too… I’m on Ubuntu 7.10 and the collada export doesn’t update just downloading the new 2.46. So I just download in the collada-blender site and everything works just fine. :slight_smile:

@knekke:
Naw, it isn’t you. Geometry by itself seems to export just fine, but if I set any sort of animation key, I get the same error (although why these objects would no longer concatenate is beyond me). COLLADA export has bugs in 2.46. (add-edit–>) Unfortunately, while you may be successful in loading a .blend file created in 2.45 into Blender 2.46 (probably okay for simple models), it still won’t export a COLLADA file for anything that you initally created in 2.46 (just tested this). Anything you create from scratch in 2.45 (even with animation) seems to export just fine. I have not yet tried a work-around, such as exporting geometry from 2.46 into a .dae file (for example) and then importing the .dae into 2.45. Perhaps some other hardy soul?

@filsd
So… what do you mean, “download in the collada-blender” site? Are you talking about downloading the plug-in Version 0.3.159 (at this site:http://colladablender.illusoft.com/cms/content/blogcategory/25/29/)??)
Or is this some other trick?
Thanks

Hey, I see this thread is a wee bit old but it’s the only thing that references this error on the stie. I suddenly started getting this error myself the moment I added keyframes to an object; it was working fine up to that point.

I’ll be looking into that blog entry now, thanks.

:slight_smile:

ETA: Actually, the version on the site is the same one that I have according to the export script header. And dowloading that one didn’t change anything. Oh … I see, this thread was about 246; I’m on 247 now.

Thing hasn’t been worked on in a year.

What a pain … pokes it with foot

hello fellow blenderers,

i have the same “TypeError: cannot concatenate ‘str’ and ‘DaeSampler’ objects”

it appears as soon as i add keyframes to an object

i’m working in ubuntu 8.10 with blender 2.48a

very bad thing, nobody found a workaround?

bye

Still no fix for this problem in 2.48a folks? Any ideas?

nothing new in this front

i also dropped a mail to the developers offering assistance, but no answer…

we switched our workflow to Ogre Exporter, quite mature at the moment

bye

Hi folks,

I just got word from Campbell regarding this, and it looks like this is working in the latest version of Blender. Can you try again to see if this still breaks for you, and if so, post a bug to tracker with a sample .blend file and instructions?

Cheers…
Mal

Hi Mal,

i’ve just tried again exporting a simple cube with keyframes, Blender Version is 2.48a and collada exporter 0.3.159

i confirm the existence of the bug, here is the .blend file:

http://rapidshare.com/files/226275421/testCubeAnim.blend.zip.html

unfortunately i can’t connect to Illusoft bugtracker, i got a page reading “Internal Server Error”

let me know if you can reporoduce the exportation error please

bye

Can you test with blender 2.49rc1, the script is now at version 0.3.160
I tried and it exported without any problems

  • please use the bug tracker. it means these problems dont keep re-occuring and get forgotten about.

i couldn’t find versione 0.3.160 of the exporter online

anyway i’ve just tried, and the problem applies to Blender 2.49rc1 and the exporter version 0.3.159

A developer linked in with Shiva seems to have tweaked some of the Collada scripts, and uploaded it - I’ll contact them now to see if they want to merge some of their fixes for the main release ( if they are regarded stabe ).

See download here… http://developer.stonetrip.com/Downloads/

Info…
Blender export scripts for Collada updates.

What is fixed?

Here what’s fixed:

  • Skin IDREF_Array joint id string values containing ‘.’ character converted to ‘_’. For example, id value ‘Foot_L.001’ will be replaced with ‘Foot_L_001’. The same way PyCollada library converts ids for ‘id’ attribute. Due to this bug skinning process fails to find Bone nodes.

  • Skin joints and poses Bind Matrix calculations are updated to take into account rotations(local orientation) of a bone.
    Used to be only bone Head Positions. Most of exported animations were incorrect before that fix.

  • Some animation keys got removed from export. The issue was with check condition on summary rotation equals to 0. Which in some cases may be full rotation or back and forth rotation.

  • Weird animation artifacts, like, stretching of an animated character shoe noses during the walk, because skin joint weights were equally distributed instead of using joint weight from Blender core objects.

@papalagi, you must be using and old script with a new blender, backup your own scripts and use the ones 2.49rc comes with.
@malCanDo, can they submit a patch to the tracker? (or you can too I guess)

@ideasman42, i’m using the script that comes with 2.49rc1, version 0.3.159, which version does your Blender sport?

confusing, the user interface says 0.3.160, but the script (colladaExport14.py) says 0.3.159 in the header
Im using the script that comes with 2.49rc1

while patching scripts in …/scripts/bpymodules/colladaImEx/
i have changed version in \cstartup.py to 0.3.160 (rev.15969), and didn’t care about headers of colladaExport14.py/colladaImport14.py - seems, they have no meaning for running collada UI, but should be corrected to avoid such confusions.

Edit: already corrected in svn-trunk

I don’t mean to add up to the confusion, but I tried to IMPORT some collada from max a few days ago in Blender 2.48.4 and it didn’t work either. I tried exporting fom max both with the built in exporter and the one you can download from feeling software (ColladaMax) without success.

EDIT By the way, I tried to send you a PM Ideasman42 but your box is full, it was just to tel you that the FBX export now works better from blender to max using 2010 version of the converter (tested on max 2008). It imported mesh hierarchy and animation all with the defaults. Thanks for that!

@malCanDo, @ideasman42:

just looking at it, hmm, it is exactly the collada script bundled with Blender 2.46, while i commited my first modifications.

Collada import is also broken here under Vista 64bit. It tells me msvcr90.dll is missing.

So i copied them files over from “Winsxs/amd64_microsoft.vc90.crt_blabla” and then i got some other error (R6034) about loading the C runtime library.

Hi,
Im pretty new to this newer version of Blender and have only just installed it. I was looking for a rendering engine to play with, first I tried YafaRay, but that didnt seem to like my Win7 x64, so I found LuxRender.
I installed but when going to Render->LuxRender I get the C++ Runtime Error B6034. Not having much luck…

Seems that Blender is doing something while starting the extrernal application that Windows doesnt like, According to MSDN something to do with not using a Manifest to open a DLL?

Probably not really the right place to mention it but as it was the only reference I could find on Google, and seems to affect recent builds I thought I should say what I know.

Using Win7 x64, Blender 2.49b, LuxRender0.61.

Ps Seems I was jumping the gun a bit, cos I searched for the error before pressing OK on the MsgBox. Looks like the LuxRender is working ok, but the error still seems to point to something so i guess I will still press the submit reply button =)