COLLADA Export bug?

I was testing with COLLADA (.DAE) export and the relative paths are all wrong, or it’s just not mapping properly when done from native blender. It doesn’t even export and import the textures into Sketchup or any video games. So I got some one to export from 3ds Max and it worked fine. Oddly, once importing the 3ds Max version, I was able to export the same one from Blender and it worked as well… so the question is, is there some setting, or a bug that’s causing the dramatic difference. :eek:

Download linky: http://dl.dropbox.com/u/11954846/COLLADA%20Ghost%20Bug.zip

If anyone could help me test this I would greatly appreciate it.
Included are two files, working blend, non-working blend and the exported files from both.
Can anyone tell me the differences? :confused:

The blend that works uses uv mapped textures.

Yes you are right, surprisingly not a difficult setting but it made all the difference. When exporting other model types that’s not always needed. Now once applied the models export perfectly.

That saved me 8 more hours of random troubleshooting different settings, thanks again. :smiley: