Colliding balls

Hi all :slight_smile:

I have a project to simulate lawn bowls colliding as part of a training course - first time doing rigid body sims in Blender, so set looked at a couple of tuts and set up a simple test scene - one ball animated to collide with another. The animation works before setting up the physics, but after that the ball which was moving before just sits there.

Would very much appreciate it if someone would take a look and see what I’ve left out.


The rigid bodies have an “Animated” check box - and you checked that for the wrong sphere. Sphere is the keyframed one, so it needs to have “Animated” checked. Sphere.001 is just driven by the dynamics, so it needs to have “Animated” unchecked.

Aah - thanks so much:)

OK - so now the moving sphere collides with the stationary one - the stationary one gets bumped away, but the moving one is not deflected. I understand that it is obeying the keyframing over the physics; is there any way to get the collision to affect both, or will I have to fake it by keyframing the moving ball to make it look like it was deflected by the collision?

Hmm. Never tried this, but can’t you keyframe the “Animated” checkbox as well (= turn it off as soon as the sphere is in motion)?

Seems to work: Test result.

Yes, that works nicely - good call:)

If only the switching off of that box could be keyframed - but still better result than faking it.

Huh? Isn’t that exactly what I was doing?

I can’t tell what you did in the video - what I understood from your explanation is that you switch off the animated box as the sim starts running - I did that and it works - but doesn’t make a keyframe and when I tried inserting a keyframe, it never happened. In other words, I have to do this every time I run the sim - it doesn’t save so it can switch on and off automatically.

Or is there some method of doing this that I’m missing - sure hope so:)

I did exactly what I wrote: I keyframed the switching off of the “Animated” box, just as you intend to do…:wink:
One keyframe at frame 1 in “on” state and another one halfway through the animation in “off” state. Just right click on the checkbox and select “Insert Keyframe”.

In my example video you can exactly see when the animation is turned off:
The sphere starts to rotate because it starts to interact with the ground plane.

Brilliant, thanks - must remember to find these hidden Blender gems by R-clicking:)