Combining Eevee with Cycles raytraced shadows

That sounds super good. Thank you very much for your responsiveness, I hope I am not burdening too much your work load :stuck_out_tongue:

All good, thanks for testing

Hi just a quick post:

I tried 2.0 only for still and I get a very noisy shadow pass.

1st image: EVray 1.0

2nd image: EVray 2.0

Same file, same set-up, also the shadow denoised is the same as the non-denoised pass.

Testing the animation later today :slight_smile:

Hi @PTCreative!

Brief summary for animation test:
Step 1 - works allright
Step 2 - works allright
Step 3 - cycles renders all the correct images but composite only the first one of the animation. Would it be possible to save the cycles pass into a separate folder? So in total there will be 4 folders: 1 Eevee 2 Solid 3 Cycles 4 Composition

As you can see the 1st image is always present after frame #1
Frame 1


Frame 2

Frame 3
![Composite_0002|690x388]
(upload://dRw6ofVW1pEICSpO28UrOUYiorh.png)

And so on with the other frames
I will try to re render everything just to double check.

Yep…I just re render all my frames and now the compositor gives me the first frame 12 times (the total number of my frames).
Just to be specific: my animation is a sequence of 12 cameras binded for each frame to the markers of the timeline.

hi @Mattakkione ,i’m not sure if that means one of the other passes didnt render all the frames, you’d need to check the output directory. Btw Your scene looks very noisy, would you mind sharing your file? my e-mail is [email protected]

Hi!
Evray 2.0 creates two folders (“EeveePass” and “SolidPass”) for the first two steps of the process, it renders all the frames with the correct sequence.
At the end of the third pass I have a third forlder called “Composite” and that’s all.
I’ll see if I can send you something, I have a super slow connection and the file is massive.

So the composite folder is empty? btw I just uploaded the latest:

remember to remove earlier versions first. Requires the latest 2.8.
thanks

Hi! Just tested the 0.3. Don’t know if you just introduced it but it’s great to see the Re-Render Shadows button. Super sweet!

For the animation maybe images are more clear:
1 list of folders I have at the end of process:
2019-05-26%2009_53_57-V-03

2 eevee’s pass

3 solid’s pass

4 composite pass

For where I am standing it will be super great if:
A-the shadow pass could be saved in its folder (as of now it’s not saved anywhere at least on my machine);
B-split the shadows render process and the compositing pass (I have in mind of using a shadow catcher solution for Cycles’ shadows and would like to composite it with eevee+ solid pass if the results are good enough);
C-we could stick to the last version of blender for a bit, as I am working with volumetrics for this particular project I am afraid that they might become buggy before the official release.

I understand that you might have different opinions on something and totally accept that :slight_smile:

Let me know if I have been unclear on some point.

PS: the shadow pass was noisy because I kept rendering the volumetric-fog cylinder that is enclosing my whole scene, as I turned it off it’s less noisy.

Looks like your cycles pass isn’t switching between cameras for some reason. Also there’s an issue with your environment background I haven’t seen before. Perhaps its the film>transparency. It should be set to True but the devs seem to be changing the line
for this feature to be more engine specific. I’m going to stick with blender-2.80.0-git.f18373a9ab1a-windows64 built yesterday, for a few weeks then. I just made the fix and replaced the file in dropbox. I’ll do a test animation and compare results.

For a separate shadow pass I agree, until its stable this is the way to go and I’ll keep as an optional method. Then you only need to multiply the shadow pass over the original Eevee pass in your own way. This is the way to make it for now in the nodegroup.

Many thanks for setting things up and for the node picture!
I just downloaded the 0.3.1 and I am going to test it after this comment.

Thanks for pointing out the background problem, I didn’t have it before because in 0.2 the shadow pass was super noisy and had to turn off lots of background elements without enabling the transparent background, my bad.

Cycles is able to switch cameras, I could see it while it was rendering the shadow pass, but somehow the compositing is off.

Anyway let’s see what the 0.3.1 brings :slight_smile: getting in touch soon :slight_smile:

Hi! All is working as it is supposed to. The last pass renders the shadows and composite everything in the appropriate way. Thanks for sticking with one realease for a while :slight_smile:
Great work :slight_smile: thanks a lot fot letting me test it :slight_smile:

great! I also added a denoise slider.

1 Like

commands-
still image- bpy.ops.render.combined(shadowOnly=False)
re-render shadow -bpy.ops.render.combined(shadowOnly=True)
Quick Shadows update- bpy.ops.view3d.evp()
render Animation passes
Eevee- bpy.ops.render.anim(renderPass=1)
Solid- bpy.ops.render.anim(renderPass=2)
Cycles- bpy.ops.render.anim(renderPass=3)

1 Like

Lots of updates for v0.4 Download
Tested on 2.8, 2019/06/08

  • render any frame range

  • shadow only option for animation final pass

  • improved denoiser

  • Better organised ui

  • clean up button, removes all EVray components

  • removed shadow tint slider, added fill light

  • improved support for transparency

  • some Quick Shadow tweaks


4

2 Likes

Sounds like a very tasty update :smiley:
I am going to give it a try this or the next week end.
Also thanks a lot for keeping the development on the 2019/06/08 version :slight_smile:
My job around EEVEE has ended last week so you don’t need to stick to that version for me anymore.
Apologies for constraining you on this :slight_smile:

So how exactly does this addon work? I just hit the render in the addon to have the shadows from cycle combined with eevee? Do i have to be in eevee or cycles? I remember having to use some kind of weird node setup and duplicating the objects to achieve this effect. If this addon replaces that, than it would be pretty nice.

Hi,
Great idea, I was thinking the same “what-if” I could combine.
I installed your addon 0.4. Ty

The following is a test scene rendered in Eevee and Cycles (screen captures)


Then EVray (v0.4), gives the following resultQ

The shadow render pass is blended in and looks very good on the floor but has awkward effect on the room walls and ceiling. The wall is too dark and one could argue that is “natural” or true, however the same surface rendered by Cycles resembles more the Eevee result. Generally Eevee and Cycles indirect lighting are indeed close!
A closer look reveals the that other surfaces the ceiling and the right wall, as rendered by EVray are off compared to both Cycles and Eevee.
An even closer look reveals mistakes:

The following is the shadow layer that EVray generates:

At least regarding the shadow outline there is obvious compositing error, with the missing lit area on the floor.

Hi all, I’ve been a bit busy lately but together this demonstration video showing the general workflow https://youtu.be/1EoDjvQAsgw

hi, thanks for testing, it would be good to see you node settings or were they default? I cant imagine what is causing that shadow issue, how many lights are in the scene?