Combining Hard Shadows and Ambient Occlusion

I’m working on a video where I’ve “added” and 3D character to real life video footage. I like the soft shadows on the character that are created with AO, but I need there to be a spotlight type shadow in the scene on the invisible floor I’ve creted in the scene. However, turning on AO makes these shadows disappear.

Are nodes the solution here? I feel like there must be some way to render the AO and then add that to a regular shadow render or something like that.

Can you upload a .blend file?

It should render both without a problem.

Nodes shouldnt be a requirement for this. Just use a light that casts shadows and be sure to turn those shadows on by selecting the light, pressing f5, and setting up shadow casting in the lamp buttons panel.

If your shadows are still coming out too soft you can try duplicating your light and setting the copy to onlyshadow. Turn off shadows on the original light and you can directly control how much shadow is being cast by adjusting the intensity of your second light.

I’ve experienced the same problem Joleo many times and have posted similar questions in this forum. I haven’t found the perfect solution yet, but have discovered a couple things you can do to strengthen the shadow on your floor plane…

  1. You can try increasing the ‘max distance’ setting for ambient occlusion. It should make more of the shadow on the ground plane appear but will also change how the rest of ambient occlusion appears on your model.

  2. You can try playing with the ‘Amb’ setting on the material for your ground plane. If the ambient colour set in the ‘world’ panel is black then increasing the ‘Amb’ setting for the material on your ground plane should darken the shadows. But I’ve found this adds slight rendering artifacts around the edges, so again not perfect.

I think the best solution probably lies in using nodes and compositing everything together how you want it. Unfortunately I’m not yet skilled enough to say how it should be done, but I feel it must be possible that way.

With regards to just adding another light that only casts shadows that you can strengthen… surely that will also strengthen all of the shadows in the scene and not just the shadows on the ground plane? I am assuming that like me Joleo you only want to strengthen the shadows on the ground plane and not everything else.

Set your shadow light to exclude objects where you dont want the extra shadows.

Is that done by adding the light to a group and then setting the material on the ground plane to exclusively use that lighting group?

That should work, but I think the easiest way is to use the “layer” button in the lamp menu, then put all the objects you dont want involved in the extra shadows on a different layer from the lamp.

I don’t have anywhere to host the blend file at the moment, but I do have some renders:

Just one sun lamp:

Exact same but with AO turned on:

I don’t have any place to host the blend file at the moment, but here are some renders:

Regular render with one sunlamp:
http://farm4.static.flickr.com/3223/2932184645_ab72a06104.jpg?v=0

Exact same setup, but AO is now turned on:
http://farm4.static.flickr.com/3010/2933056110_21dc2fe9bc.jpg?v=0

Honestly the shading of the character doesn’t look that much better with AO on. I must have changed some settings! Haha!

Oh well. What I’d really like to do is render in Yafray, but my video background doesn’t show up.