compile blender for mac... how to?

Anyone have a link or info on how to compile blender on my own for my intel macbook? wanting to try the svn and the “plumiblender” versions.

anyone?

bubs

I don’t have a mac, so I can’t really test this, but the blender wiki has this:
http://wiki.blender.org/index.php/BlenderDev/BuildingBlender/Mac

Sweet I’m checking it out now! Thanks

ok so I tried this bit of info for a while and I cant get it to work. Well, first I tried to install Scons on intel leopard but no luck with that.

but this little bit is making trouble (bold)

  • Open /Applications/Utilities/Terminal
  • Set the home directory for your blender source code in an environment variable, like so (assuming you’re using bash): export NANBLENDERHOME=<path to bf-blender/blender>
  • Type cd $NANBLENDERHOME
  • Copy the appropriate snippet of bf-blender/user-def.mk below, to your own bf-blender/user-def.mk file.
  • Type make Make will spit out lots of information about what it is doing. When something goes wrong, and you need to see exactly what make did, try:first NAN needs a $ in front of it. I can’t seem to set the variable. I know “path to blender” is the actual source I downloaded. that is still confusing to me. but anyway, I get an error for the “=” and the actual path to blender.

Has anyone compiled the plumiferos build for intel macs yet? I know they have a PPC and a windows build but not an intel on graphicall. I was interested to see what they added to the animation and rigging areas.

anyone know where I can get some help on building this on the macbookPro?

bubs

in the first NANBLENDERHOME line, it shouldn’t have the $, it should just be:


export NANBLENDERHOME=/path/to/blender/source/

like I said, I don’t have a mac, but at least this part should work as long as the path doesn’t have any spaces in it…

OH. I forgot the leading forward slash. Thanks as you can see I’m pretty new to compiling blender.

thanks for the help

I don’t get the part where you copy the appropriate snipped of bf-blender/user-def.mk…
This is the first time I try to compile anything and I have been going all over the place looking for how to’s but I always either get completely lost or get errors like ./configure doesn’t exist etc…
Can anyone hep me out?
I’m running leopard on an intel mac and am completely lost.

Jonathan
It is much much more easy to use scons:
This build system is the best maintained for blender and works
out-of the box mostly.

On leopard: get SVN for checkout´s, scons as builddsystem and develpoertools
from apple - thats all.

In blender.org forum is described how to build, it a bit outdated but still o.k.

Cheers…Jens

@ JonathanC: The instructions there were from the link provided by dreblen.

Scons is probably easier but I had a hard time getting it to install. I finally did get it installed but haven’t tried to compile blender yet.

Finally compiled blender with davidlandwehr’s patch! It works, no bugs. I think i might write up a tutorial on how to do this for Macs… I had to go all over the place to figure it out. Well I was very much a beginner when I started but I learned a few things on the way. Thanks everyone for your responses!

Sweet did you end up using scons?

A tutorial would be great! I gave up trying to compile once I had trouble getting scons installed on my mac. I finally found out how to install scons but never went back to try to compile blender…

http://landwehr.dk/MacMini.patch
I used this patch.
I’m not sure if you’re familiar with how to use a patch but on mac “patch” is already installed. So what you do is download the source code for blender.
Save MacMini.patch somewhere for example, jonathan/blender/patch/
Then go to the place where the source code (for me that’s jonathan/blender 2.47/) is and enter the following:
patch -p0 < jonathan/blender/patch/MacMini.patch

This should not give you any errors.

Then you go to jonathan/blender 2.47/config
Open up the darwin-config.py file in a text editor, change the following lines to this:

USE_SDK=‘false’

BF_PYTHON_VERSION = ‘2.5’

if BF_PYTHON_VERSION==‘2.5’:
BF_PYTHON = ‘/System/Library/Frameworks/Python.framework/Versions/’
else:
BF_PYTHON = ‘/System/Library/Frameworks/Python.framework/Versions/’

For me, I had to do the following, you might not,

In the terminal:

  1. got to : jonathan/blender2.47/extern/xvidcore/build/generic
  2. type: ./configure --disable-assembly --disable-mmx
    press enter
  3. type: make
    press enter

Then, go back up to the jonathan/blender2.47 with the terminal,
usually just type scons and enter, it should work, if it doesn’t, you may have to add something after scons. I hope this helps!

Special Thanks to: jensverwiebe

If you want I could post my build…

I wrote a tutorial on my site: Blender Resources |

Killer , does your way of building blender on Mac fix the bug that is found on Macbooks?

What bug? Follow the tutorial and find out =P

Macbooks running on intel chips have a bug with the interface, apparently, it has to do with double buffering… (or something of the sort).