Compile error SVN, Scons and Ubuntu

Hey Guys,

I am running ubuntu and since I have had major problems with Ibex I have rolled back to Hardy

anyway - I have done a lot of things to break my machine and then repair it

I usually know how to fix compile errors are build blender but I am confused by this error
(it has never got stuck here before)

I know somebody will be able to help me out

this is the error


Compiling ==> 'buildinfo.c'
Linking program ==> 'blender'
/usr/bin/ld: cannot find -lGL
collect2: ld returned 1 exit status
scons: *** [/home/waylow/Blender/build/build/linux2/bin/blender] Error 1
scons: building terminated because of errors.

what package do I need to fix this one? or what config settings do I need to change

don’t know what -lGL is

-l is linker directive to include a (standard) lib --> (at least for gcc)
GL is OpenGL for Blender UI drawing

Check that you have got all the necessary packages installed (IIRC, Ubuntu is quite stingy on this, and doesn’t include many packages needed for developing out of the box). Dunno the specifics, since I compile + develop Blender on Windows… :smiley:

found it,

installed nvidia-glx-177-dev
and removed the packages that conflict with that one

it has now built and runs

I have not yet rebooted yet to see if everything still works correctly after a reboot but now I know the

It’ll be fine, I had the same error and found the same cure a few weeks ago on 8.04 64 bit.
Still can’t build with game engine though.

Yeah, it’s still working :slight_smile:

I had to roll back the kernel as I said
and now I find breaks the graphics driver evert upgrade that happens

so I have to reinstall the graphics driver when this happens

Sucks you can’t build with Game engine

maybe you should start a thread for us to help solve the problem :wink:

post the error etc

I did try posting a couple of times about it when I was having the
cannot find -lGL error, but nobody seems to know.
I get this:-

Compiling ==> 'VideoFFmpeg.cpp'
source/gameengine/VideoTexture/VideoFFmpeg.cpp:26:1: error: "__STDC_CONSTANT_MACROS" redefined
<command-line>: error: this is the location of the previous definition
Linking library ==> 'libsrc.a'
Compiling ==> 'ImageBuff.cpp'

then some warnings, and then this:-

In file included from source/gameengine/VideoTexture/ImageBuff.cpp:31:
source/gameengine/VideoTexture/FilterSource.h: In member function ‘virtual unsigned int FilterYV12::filter(unsigned char*, short int, short int, short int*, unsigned int, unsigned int)’:
source/gameengine/VideoTexture/FilterSource.h:224: warning: suggest explicit braces to avoid ambiguous ‘else’
scons: *** [/home/organic/build/linux2/source/gameengine/VideoTexture/VideoFFmpeg.o] Error 1
scons: building terminated because of errors.

I tried a whole bunch of different -dev libs but nothing works so far, and I can’t make much sense of it.

That sounds like you might need the help of JesterKing (he is the expert on compiling)

I’ve never seen anything like that before

but to me it seems that file it is referring to might be corrupt

you could try deleting the gameengine source folder (or that file) and then checking out the source again

this will then grab that file again

But isn’t h.224 is the codec for Quicktime? - What OS are you running (Windows?)

I did ask jesterKing and I also tried renaming the directory and updating, then a fresh checkout of the whole thing. I am using 64 bit Hardy.
jesterKing thought maybe it was to do with the way ffmpeg works on different systems, but that(as far as I know) is unconfirmed.

so have you tried to build with FFmpeg disabled in your config

(I’m pretty sure you would have but I thought I would ask, just in case)

Yeah, jesterKing mentioned that too, but then I wouldn’t be able to render animations using ffmpeg, and it was the ffmpeg video texture thingy that I was interested in.