Compiling 2.5 with scons on win64? /Building and Scons in general

OK, so I can compile 2.5 fine on my XP MCE win32 system with MSVC C++ Express 2009, but I haven’t been able to get 2.5 to compile on my win64 laptop with the same approach yet, so I thought I would try scons.

I don’t know anything about scons except that its a build system different from CMake. :stuck_out_tongue:

I’ve been following this guide but to no avail so far. And I vote for an official build sticky. :stuck_out_tongue:

And I feel bad for having 2 different build threads.

Could a mod merge these and keep them in the off topic area?

Thank

LC

Won’t build huh?

There wouldn’t happen to be some useful error messages or anything like that would there?

Might, you know, help…

Could be. :stuck_out_tongue: I’ll post it next time I try it.

I’m also trying to build via scons on my win32 XP MCE machine, getting no where. :frowning:

I keep getting:

‘scons’ is not recognized as a an internal or external command, operable program or batch file.

Install scons and put the path to it (possibly by using a batch file, if you don’t want to pollute the path) in your PATH environment variable.

Hm, Pan omitted that step. :stuck_out_tongue:

I’ll try that, but I know nothing of batch files. :stuck_out_tongue:

EDIT: Odd. Scons doesn’t have a directory location persey, but installs in the python directory.

I have 3 different versions of python; 2.5, 2.6, and 3.1. Could this be the problem? I think I have multiple scons installations with them as well.

Choose whatever version you’d like to use and install Scons for that version :wink: and yes, it installs into the Python directory.

Done already, still getting errors.

My paths seem to be correct. XD

What do you see in the path var when you’ve typed “set” in a console window?
(if you don’t know what I’m talking about, you should brush up your knowledge about console commands and environment variables first)

I think I’ll have to do that. I don’t know much, if anything about console commands.

To be honest, all I really know is that old computers were command line based, and that old windows systems were DOS based, which was command line based, and that it remains integrated for lower level functions.

Something like that?:o

Well, these days it’s just a set of functions you can use to navigate on your disk (like using Explorer, but command based instead) and a lot of additional things (for example, you can query or set a lot of Windows settings directly at the command line).

Most important thing to know is this:

  • if you open up a console window and don’t know what to do: type “help” (without quotation marks)
  • if you want more info about a command and its options, type “commandname /?”

Easy :wink:

Anyway, I told you to type “set”, but you can also type “path” instead. Try that, and check if the path to scons is in it.

If it’s not, type “set PATH=%PATH%;C:\PythonXx\Blah\Blah” (fill in the correct path - semi colon is for seperating values). You should be able to use Scons after that.

You can also permanently add a new path by going to the start menu, right click “Computer”, “Advanced system settings”, “Environment Variables…”. You’ll see the PATH variable in there as well. Twice. The first is for the system account you’re currently using, the second is for system wide settings (ie. on all accounts). You should be able to use Scons after doing this, as well (restart the console window before you continue).

I think the graphical way is best for you :slight_smile:

But to be honest, I do think you should play around a bit with the console as well, it’s always good to know more about it when you start doing stuff like this. It gives you some more insight in how things work behind the scenes.

[quick reply, I’m about to run some errands]

Probably so.

One reason I was looking into the scons method is that the author of that guide noted that you could simply zip up the resulting files for distribution.

Can I do the same when I build the graphical way with MSVC, or is it slightly different?

Also, I still want to build it on my win64 laptop.

Is Blender not building on 64 bit systems?

Its fine if its just 32 built on 64 system, but I’m not sure why it won’t build. I think all my build tool are 32 bit.
Also I’d still like to

With “the graphical way” I meant “to use the graphical dialog to set your environment variable” :slight_smile:

Anyway. Yes, when you use the IDE to build Blender, everything is the same. Whether you use CMake or Scons, you can just zip up the directory with all the executables and libraries in it and distribute them. For CMake, this is the “release” directory (that’s why my archives on GraphicAll.org contain that directory, it’s really just a straight zipped up copy).

Also, I still want to build it on my win64 laptop.

Is Blender not building on 64 bit systems?

I’m still using x86, so I don’t know if Blender 2.5 can be built for 64-bit systems, sorry.

Its fine if its just 32 built on 64 system, but I’m not sure why it won’t build. I think all my build tool are 32 bit.

Well, at least you’ll need the x64 compilers and tools for it to work (see installation program). If you don’t have them already, they should be installed.

Can’t help with actually using them, as I’ve never compiled any program for x64 yet.

Also I’d still like to

Yeah, me too!

(whut? :p)

I see. Cool.

And I just have to throw python31 in there right? Also zipped?

That’s what I always see with the builds, some python version zipped with them.

I’m still using x86, so I don’t know if Blender 2.5 can be built for 64-bit systems, sorry.

Of course, I just want to build the 32 bit blender on my laptop, which is win64.

Yeah, me too!

(whut? :p)

Oops.:o

I posted this around 8:30 or something and then I went to get my books for next semester.

Obviously, I forgot to finish my sentance! :stuck_out_tongue:

(And btw, I hate it when people do that! lol :p)

Ok, tried building it again; 2.5, revision 22447.

Which build logs do you want, just the ones with errors I assume, how should I post it? With the directory info too I assume?

Ok, tried building again today.

Still failed, but the number of failed projects is down, from 11 to 6, so I guess that’s a step in the right direction? :stuck_out_tongue:

Still building with MSVC Express.

Now, what I didn’t mention before, and this applies to the successful build on my desktop, is that I had to manually tell it where the libraries were. For some reason its not automatically detecting the lib folder.

I thought CMake was supposed to do this?

So I tried inputting the paths manually in Options>VC++ Directories and I still get errors; there seems to be non-existent folders its looking for.

One persistent error is that its looking for “ft2build.h”

I can’t find this. Also its complaining about AL/al.h even though I have OpenAL setup in the paths now (again, manually :mad:).

Attached is a screenshot of my VC++ Directories dialogue box.

EDIT: Scrolling through the log briefly it seems to have built successfully for the most part.

If I could just figure out what ft2build is and why its whining about openal I think it would work.

EDIT: OK, so ft2build is a freetype thing.

Rebuilt my solution and it seems to be building fine now…

Lol; well now its down from 11, to 6, to 5, and now 3. Must be getting closer! :stuck_out_tongue:

GRRRRR! The build log tells me nothing this time!!! Although I still have 3 errors…XD

Attachments


I’m so close to building Blender 2.5!!

But I keep getting a linker error about libjpeg.lib.

What’s so annoying is that I shut it off in cmake and I STILL get the error!!:mad:

54>LINK : fatal error LNK1181: cannot open input file ‘libjpeg.lib’

EDIT: Looks like it may be related to the Direct X SDK. I thought I had that but I guess I don’t. I’ll download it again sometime today and see if that helps.

Installed DX9 SDK and now I’m be getting tons of errors.

Build log says 54 failed 1 succeeded.:smiley: