Compiling Blender in Qt Creator failing ?

Hi

I am trying to compile Blender(win32) with Qt Creator on Win7 64 with Mingw32. I cannot figure out why it is failing. Maybe someone can give me some insight.

I opened the cmakelist.txt under the Blender svn folder in Qt. Then I run the cmake configuration. Once that is done, the Blender code base was open in QtC, then I chose “build blender”.

I know there was a note about using the Blender python script to create Qt project on the wiki but that did not work for me either.

Here is a paste from the log

http://pastie.org/3553205

thanks

Does nobody know?

Not pulling in libraries for zip and boost etc.? Try -v for more verbosity?

I use mingw32 and QtCreator without problems - hint - first get it working outside qtcreator, (mingw32’s make).

Ideasman42,
Do you use the cmakelist directly in Qt or do you use the python script from Blender to create the project?

I will try standard make, thanks for the tip.

First I get everything running outside of qtcreator - typical mingw-cmake setup, which I help maintain (that isnt really much work).

This is nice since it means your not locked into any particular IDE or editor.

Note that I don’t use the MinGW thats bundled with QtCreator, though I tried it once and it worked ok, it was just a version or 2 behind.

I use the project files generated by cmake_qtcreator_project.py

Hi

I am unable to compile it properly even with make (from Cmake-gui).

Based on all the tutorials I see on compiling Blender on Windows, this should just work out of the box(straight from svn checkouts of the blender source and the libraries). But I am unable any result so far :frowning: I tried to disable most of the features during the config.

Here is the log

http://pastebin.com/DxLV0ah9