Compiling blender on windows.

Is it possible to compile blender on Windows XP using free tools which don’t need half a gb of stuff downloaded?

(The .net SKD framework 108MB, Platform SDK 300MB, DirectX SDK 200MB)


Brian

cygwin, probably only 300Mb…

actually I have no idea how big it is but you can build blender pretty easy with it

cvs -d:pserver:[email protected]:/cvsroot/bf-blender login
cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co lib

cvs -z3 -d:pserver:[email protected]:/cvsroot/bf-blender co blender
cd blender
export FREE_WINDOWS=true>user-def.mk
make

[or something]

[the cvs is pretty big, prob 200Mb total. you dont need all of lib however, just lib/windows]

I have cygwin clocking in fully at 1.75Gb… not all of which you need

so I guess the answer is:
NO, this stuff will add up to that big probably

[oh, you dont’ need directx to compile blender]

I haven’t played with compiling blender using other than make and gcc [ or mingw], so I couldnt’ comment on how to do that

i use cygwin, www.cygwin.com
http://dani2.chez.tiscali.fr/compilation.html here a tut for setting up cygwin, and compiling blender

my blender source dir + libs dir is 162MB and my cygwin dir is 333MB, but i have a lot more things installed than you need

Isn’t blender compiling migrating to using scons?

So I would need a compiler which works with that.


Brian

You can also fake out the Platform SDK into not downloading 100s of MB of useless crap like documentation and samples etc. by starting the full download, cancelling it, then you customize the install to only select the core build tools.

I downloaded: 50MB of Cygwin, 50MB of Platform SDK, and the 30MB Visual Studio command line tools.

Scons is like make. You tell it which compiler to use.

I tried Scons, but it crashes the first time it calls the compiler. (“This program has performed an illegal action and will now close.”)

Cygwin works fine but compiles Blender without sound. It’s because there’s no mingw/gcc compatible Fmod or OpenAL libraries in lib/windows. I have found a libfmod.a and libopenal32.a that work, (tested them personaly,) but haven’t found where the makefiles need to be changed to use them when compiling :-?

I don’t quite follow how you did that.
Could you possibly explain it in more detail please?


Brian

I don’t quite follow how you did that.
Could you possibly explain it in more detail please?

  1. Go to http://www.microsoft.com/msdownload/platformsdk/sdkupdate
  2. Click “Windows SDK” from the menu on the left
  3. Click “Install this SDK!” from the panel on the right
  4. It says “Confirm Install Selections”. Click the Continue button.
  5. Accept the license
  6. Click Install Now
  7. Click OK on the security risk dialog
  8. Click cancel then OK in the download box.
  9. Click close to cancel the download box.
  10. Now, you get to the “SDK update catalog”, and you can choose the components you want to download. You only need: “Build Environment (31 mb)”
  11. Continue the Download.

Get The Visual C++ Toolkit: http://msdn.microsoft.com/visualc/vctoolkit2003/
And Cygwin:http://www.cygwin.com/

OK - but does this method actually copy the download onto your machine ot is it simply an install from the web - reason I ask is that I’ll be reformatting my machine in a few weeks when I do my system upgrade so I woudn’t want to have to install from the web again!


Brian

It installs it from the web. You can grab the .cab files downloaded out of IE’s cache, but I haven’t tried reinstalling, or installing on another computer.