Compiling Error: buildinfo.h not findable

Hey Folks,

I’m running Windows 7 Professional(64Bit) with Visual Studio 2008 Professional and CMake 2.8.10.2.

First I’d checked out the svn with Tortoise SVN (“blender” and “lib/windows”) for updates.
Then I’d builded the files with CMake (Buildsettings: Default, without Cycles and for “Visual Studio 9 2008” )
=> CMake gives one error:

CMake Warning at CMakeLists.txt:2020 (message):   'numpy' path could not be found in:
    '/python3.3/site-packages/numpy', '/python3/site-packages/numpy',
   '/python3.3/dist-packages/numpy', '/python3/dist-packages/numpy',
   WITH_PYTHON_INSTALL_NUMPY option will be ignored when installing python

But obviously it will and can be ignored.

At the next step I’d opened the project Blender.sln(as administrator) and start building the project “INSTALL” and after it “blender”.

“INSTALL” works pretty well with no error, but “blender” has some problems, btw. one problem/error:

Fehler    1    fatal error C1083: Datei (Include) kann nicht geöffnet werden: "buildinfo.h": No such file or directory    c:\BlenderSVN\blender\source\creator\buildinfo.c    34    blender

or translated:

Error    1    fatal error C1083: Can't open File (Include): "buildinfo.h": No such file or directory    c:\BlenderSVN\blender\source\creator\buildinfo.c    34    blender

In fact there is no “buildinfo.h”.

Why is there no “buildinfo.h”?
Is it possible to build my own file?
Is it possible to modify “buildinfo.c” that it will ignore “buildinfo.h”?

It would be really cool, if someone knows a solution, because I want to start developing blender and especially the game engine. :slight_smile:

Thank you,
Flo

Try building the solution first.

before it starts linking you’ll see something like


73>------ Build started: Project: blender, Configuration: Release Win32 ------
73>Compiling...
73>buildinfo.c
73>creator.c
73>Generating Code...
73>Linking...

The buildinfo.h will get generated into your cmake/source/creator folder and will look like


#define BUILD_REV "54100"
#define BUILD_DATE "Sat 26/01/2013"
#define BUILD_TIME "05:16 AM"

Hmmm I’m either up early or late.

then build INSTALL

Okay,
thank you, but like I’d said the file won’t be created.

I think the problem is CMake, which doesn’t create the file.

I’d recognized, that CMake has an error “Could NOT find Subversion (missing: Subversion_SVN_EXECUTABLE)”.
What is missing or what should I change?

[Edit: After adding the “buildinfo.h” with your code, this error doesn’t occur anymore, but now there is the following error:

Error 1 fatal error LNK1104: File “…\lib\RelWithDebInfo\bf_windowmanager.lib” Can’t be opened. blender blender

]

Edit2: I’d solved it. I’d builded “blender” wrong. Now it compiles correctly, but with many other Errors. I think I’d checked something wrong at the build-settings(cmake). Could this be?
Flo

Forget my previous post re build INSTALL. I generally build the solution first then if that goes Ok build install if it linked Ok and the revision has been changed.

Your issue here is not having the path to your svn. In the version of cmake i have i need to click advanced options and Cmake_SVN_EXECUTABLE is under “ungrouped_options” with numpy and cuda. Without this it wont be able to create the header file, which as you can see, has the revision and timestamp. I don’t remember setting this.

Hope you get it up and running soon.