Compiling Error svn r60149 (OS X)

scons building r60149 on Mac OS X 10.7.5 64 Bit gives this error:

ld: archive has no table of contents for architecture x86_64
collect2: ld returned 1 exit status
scons: *** [/Users/paolo/blender-build/build/darwin/bin/blenderplayer] Error 1
ld: archive has no table of contents for architecture x86_64
collect2: ld returned 1 exit status
scons: *** [/Users/paolo/blender-build/build/darwin/bin/blender] Error 1
scons: building terminated because of errors.

Thank you,
paolo

I’m with the same problem… glad you posted here.

I’ve run into the same problem. Hoping someone can offer a tip if not a solution.

It should be due to latest changes by Jens Verwiebe in r60146 or previous.
We just have to wait and hope…:rolleyes:

paolo

I jumped to cmake and it worked.
It’s simple, just follow this instructions:
http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Mac

Well… I have some problems to build with openmp… I don’t know how to build with openmp this way…
But it’s compiling.

Same Error here. Scons, Clang, r as of today, osx 10.8.4, XCode 4.6.3

This needs to be fixed. And i wonder how the buildbot is able to build?

Does Jens know about this then?

I don’t think so, I am not able to inform him.

@ eversimo,
thank you for the link, I have to make an attempt with cmake, btw, so far I never succeeded to build openMP with scons.

paolo

then that could be a hopeless wait :wink:

i will see if i can do something on that matter…

The latest source builds fine for me with cmake/Xcode 4.6.3 on 10.8.4 without OSL, OpenMP, or FFMPEG (prolly just need to add the libs for OSL or FFMPEG). For openMP, I read that Apple is moving away from gcc to clang frontend for llvm (which doesn’t support openMP as of yet) so that could be a problem if you want to build openMP from it.

How do you set your cmake to enable openmp?
I just check the box to enable openmp but cmake can’t find a proper flag…

As he wrotes i don’t think he activated openmp. OpenMP on osx is kind of a pita. You need gcc 4.7 +

osx built in clang nor gcc support openMP

I build blender trunk daily, (well… not anymore because of this scons error…) and I was always able to build with openmp. I’m using gcc 4.6.2 and i followed this instruction for scons: http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Mac/OpenMP
But with the same gcc I can’t build with openmp via cmake and Xcode…

you’re right, it’s gcc 4.6.2 +

but using another gcc in xcode than apple ones gets tricky…

Still, we need this scons thingy fixed.

@eversimo: do you upload to graphicall? ever considered? I’m asking cause there are not much osx uploaders, and my trunk build is not able of being updated for two months now…

Yes… but I don’t know how to solve a dependency. When I build with openmp I can use Blender just on my machine, because of my custom gcc folder… I can upload only builds without openmp. But I will start doing this! When this scons problem is solved.
Is there anything we can do to make Jens to know about it?
How can we contact him?
Should this be reported as a bug?

i would not consider it a bug. his mail is [email protected]

you can write him, tell me if you do, otherwise i will do it later

I wrote him right now. Waiting response.

Thank you eversimo :yes:

EDIT:
about OMP compiling, the problem I had in my attempts with scons and gcc 4.6.2 was that the compiled blender crashed immediately on startup.

paolo

Did you followed this steps? http://wiki.blender.org/index.php/Dev:2.5/Doc/Building_Blender/Mac/OpenMP
I followed this steps and it worked fine.
I just left this step behind: Add to the PLATFORM_LINKFLAGS ‘-static-libgcc’
I think this cause some problems for me so I don’t do it.