Complete newb lost on non-manifold vertices...

Forgive me this is a really stupid and/or easily answered question, by I’ve been juggling Blender, TurboCAD 16 deluxe and Meshlabs for the past seven hours and my brain has just given up (and this is the SECOND TIME I’ve had to write this post up because the boards ate the first one, so now I’m annoyed as well as frustrated and lost!!!)

My ultimate plan is to design some starship models, in TurboCAD, where I’ve had simply years of experience (like about 15 or so) and can do so with reasonable expediency, them export them out to be used at Shapeways or other similar places.
The first problem is that, without the Pro version, I can’t make surfaces per se, nor can I export directly to something useful like .stl.

I figured can work round this minor problem in two ways;

  1. use TurboCAD to draw the wireframe and use blender to make it into a usable surface/non-manifold thingy

or 2) Create 3D shapes in TurboCAD by making my polylines into 3D shpaes by adding a thickness (for the sake or arguement, 0.1mm). Then I could simple boolean these shapes into an effective solid, single surface.

Under the second method, I managed to get all the way to doing the model, exporting it as a .dae into mechlab and out as a .stl and uploading it to Shapeways. Where I found to my lack of surprise, that it had some errors; specifically non-manifold errors. After some effort trying to translate their demonstration video’s altered blender interface, I managed to get a look at the file, and discovered that, because of the ‘wall’s’ thickness, the complexity of the location of the non-manifold points meant I had no clue how to go about fixing them or even what the problem was.

So I went back to option 1, and working from the wireframe. Now the problem there is that I can only get files from TurboCAD into blender via .3DS and .DXF (both of which go a bit whacky) or vrml 1.0. I can’t use .dae, because meshalb crashes out if presented with a file with no 3D objects in it, and blender doesn’t pick anything up.

Trouble with the .vrml is that not only is everything non-manifold, but there are multiple verticies co-existant that blender’s remove double doesn’t seem to affect.

I even, from when I last made an attempt at all this (back in May before my hard-drive failed and I hadn’t gotten around to reinstalling everything), have a blender file of the model with all the faces done. Which is also all non-manifold; from my perusing of various things at Shapways, I assume this is because they are conincient edges.

Now utterly lost, I slapped a mech cube in to try and work out what the difference was, and found that that, too, is apparently non-manifold.

At this, point, my brain simply stopped processing. I’m now not even sure as to what I’m even looking to do. I’m assuming there’ some sort of function to turn faces into a surface, or boolean add them together or something, but I don’t even know where to begin.

So If anyone can offer any help (on any part of this muddle), I’d be grateful. (Though you should assume I know nothing about blender, python or 3D modelling; because apart from wireframes in TurboCAD, and the little course I did on ProE in university during my engineering degree, I pretty much don’t!) Even if it’s just to point me to the right bits of the FAQs or something.

Eve if its to tell me the idea is so abbhorrently assinine, insane and generally dopey that I should quit while I still have some limited cognative function…!

You sound as if you are making this as difficult as possible for yourself bouncing from one application to another. Bite the bullet and try using blender from scratch. Watch some of the getting started tutorials, get the basic understandings of how blender operates and use the knowledge you have already to apply your turbocad knowhow in blender.

In blender, don’t rely on booleans, they generally result in a horrible mesh.

Richard

well i would simply suggest to do it directly in blender it has all the tools necessary to do the job and it’s free!
i know you said you don’t know much about blender but it 's not that hard to use
except it’s in 3D so you got o get use to this and it beccomes easy with time
now if you hve specific questins you can always ask in the forum here
and people will be glad to help you with whatever problem you have !

now for import can you export as OBJ this should be easy to import into blender
there are several good import script that youc an use also

hope it helps

Or you could try the Turbocad -> Sketchup -> Blender. via Collada (rename Google Earth file to .ZIP, import DAE to Blender using Collada 1.4 imort); or OBJ (free - basic - exporter is available). Working via Sketchup has the added advantage that Turbocad 16 has 2 way support for it.

You could do the base model in SU, then tweak, texture and animate in Blender.

Just a suggestion FWIW :slight_smile:

Aha. That might well, then, be what I did last time before I aborted when I switched the hard-drive over. I think I did briefly mention that I’d tried TurboCAD-Sketchup-Blender the first time I wrote that post, though it clearly got lost in the second. As it would explain how I’d managed to surface that one wireframe in the blender file. It does sound like a slightly better option.

So, this still doesn’t answer the other problem, though; once I’ve got A. N. Model in blender; primarily so blender can check for non-manifold verticies, how exactly does one make them manifold? The shapways examples were not helpful, seeing as they didn’t show what menu options were being used. Given that if I just stick a cube in from blender’s native menu, and it’s saying it’s non-manifold, I’m guessing there’s some sort of function I’m still missing somewhere along the line. Or I’m just incompetant or something…

can you upload a file with a simple object you say and how you get this error of non manifold object

i mean a manifold is usually and object with some concave faces

so i don’t understand you get this with a cube>?

Happy blendering

I agree. Could you post a stripped-down file? Or at least a screenshot?

According to the Shapeways sitethey take only 2-manifold objects - where each edge is connected to exactly 2 other edges. And, an easy way to ensure everything is okay is to pass it through the Meshlab import/export. Both of which you’re complying with.

What exactly was the problem with the SkUp route? But, then, maybe the best approach would be to export the “guide” shapes to Blender via DXF, and do your 3d there. This would ensure a clean model. BTW, I assume you know the easy way to add thickness - with the “Solidify” script?