Complete White Background With Filmic

Hi everyone,
I am wondering is there currently any possible method to do a completely white background in filmic?
Since color management affects the compositor, simply adding a white background in the compositor does not work, and increasing the value destroys the image ( I don’t know why ).
So did anyone find any method other than doing it in an external software (which consumes time quickly especially for batch renders)?

Increase the value. It should work. If not, post the compositor nodes or a representative test of the project. One thing, some color data and operations may not like >1 values, can this be it?

When you boost the value it gives bad results around the borders of the alpha and in the shadow catcher.

I will try to post two comparison photos when I am able to, but basically the image borders and shadows on the shadow catcher are affected.

Oh, ok. Alpha and shadow catcher use is not something I use so out of my comfort zone. I just tried it with my startup file and I had no issues. These were not mentioned in the OP - it helps describing a problem properly or supplying a file.

Sorry for the late reply, here are some test renders I did for a project:
1- This is how I want it to be, I basically took the render with the alpha and placed it on top of a completely white background in GIMP.


2- This is when making a mix RGB node in the compositor with the factor set to the render output alpha and the color set to very bright white with value 3.5 to achieve (1,1,1) white in the end result.

And here is the node setup.

As you can see (at least with this node setup), the shadows of the shadow catcher are completely removed. If I tune down the value a little bit, the shadows, although may appear, will also be much lighter than the result I want.

Filmic is for better representation of the dynamic range of the scene. It’s normal for it to make anything white that isn’t a light source less white. If you need the background to be pure white, then you could try either changing the color transform from filmic to standard (Render Properties > Color Management > View Transform dropdown), or use the compositor to set the value for the background to something high enough to make filmic assign it to be white (This sometimes makes lamps less bright:

2 Likes

I understand what filmic does and I like using it that’s why I don’t want to switch to standard.
The problem is that I only want the background to be completely white without affecting the image. This can be done easily in external software by placing the render (having transparent background) placed on top of a completely white layer.

I mean that as long as you run it though filmic transform, it will always affect the background even if you are using the compositor to add in a color. If you want to do it in one go then you’ll have to increase the value of the background to the point where the filmic transform assigns it to be white.

The only other options would be to just do it in gimp, or save it to png, then composite it in blender’s compositor while it is set to standard.

You could try tweaking the value of the color until it doesn’t cause filmic to mess up the shadows.

Here’s that text scene with the background value set to 4.875:


It makes the lamp less white and messes up the shadows.

Now here is that same scene with the value for the background set to 2:


That gives a much better result without affecting the rest of the scene too much.

The reason setting the background to be over (1,1,1) white doesn’t work should be clear if you check my test renders above in this post.
Doing it externally in GIMP works well but it slows the workflow specially when I batch render multiple images. When I want to render 100 images with white backgrounds this method is just unpractical.

Yes, I’m basically trying to say that the only other way to do it is as a secondary step. The filmic stuff is applied when the file is saved. We don’t have any way of keeping it from affecting the foreground separately when we are working. The next best thing you could do is render all the foreground frames as a sequence of pngs with the transform set to filmic, then import them into another blend file with the transform set to standard before you start compositing them into a background.

1 Like

I feel like you missed the basic problem with the composite.

Don’t use a Mix node, use Alpha Over.

In this case the mix node should work just as well since hes just replacing the background. The main issue is the fact that the filmic view transform is only applied when the file is saved. We don’t have any way of having the compositor apply different transforms for different parts of the image.

Have you found any efficient way to achieve this? I’m having the same issue now with a scene of 50 images… driving me crazy that this is not something possible

Just putting in my 2 cents, for you guys that want to process many images. Save your filmic images with transp backgrounds first. Then, open a new blend file, set color transform to standard, go in the compositor, and select all your images as an image sequence. Finally pass them all through this node setup and voilà!

Let me know if that works.

5 Likes

Great solution!
Does the image rendered in filmic get affected at all when used in standard color transform?

They don’t, once save from filmic, they are “frozen” as what they look like. In fact, the images will look different if you do the compositing WITH the view transform set as filmic.

Hey, maybe you could help? I’m trying to do basically the same thing as the OP. I followed your advice, however, I think the image does get altered?

Left is your suggestion (setting the plane to shadow catcher, then doing the compositing on a new file, import to photoshop with white background), right is the viewport with a solid white plane behind it.

Notice how the shadows are much darker when exporting (left)? And also the shadows are full black, as if they’re missing reflections, whereas when rendering there’s a redish tint to them?

Can’t upload the blend file yet though…

That works as expected. With a white plane behind your red cube, the plane receives red scattered light from the cube. The same thing can’t happen with a composited solution.

Both ways are valid depending on the result you’re after.

There have been a few changes to the compositor since I wrote that, and I believe that now the rendering and composition can be done in the same file. You can choose a different color space for the evaluation of the comp. image.