⛔ Completely pitch black Shading when roughness set to 0 (zero) on EEVEE

Hi BlenderArtitsts.

So since I upgraded my Blender installation from 2.92 to 2.93 I encountered this problem with every shader where the roughness is set to zero: Shader gets completely black!

As you can see in the next GIF, I set the roughness to absolute zero and no matter the other settings (specular & metallic) shader always stays black. I then switch to Cycles and, as expected, works properly.


Curious thing is… this problem starts to occur before reaching zero; it appears to be that the threshold is 0.003726621. At 0.003726622 or above, shader works right. At 0.003726621 or below, shader gets completely black.

This is a devastating hit on backwards compatibility due to me having many shaders with zero roughness that are now completely broken.

FYI, this problem appears only on Blender 2.93 and 2.93.1 (latest version), on Linux as well as on Windows. Blender version 2.92 deals with zero-roughness shaders just as well as expected.

Thanks in advance and I really hope you can help me resolve this.

I’ve been having the same problem! I really hope we can get this thing resolved.

That’s strange, I have not found this problem. (I tried to recreate your shader settings)
I am on linux, currently 2.93.1 release candidate, but I have been through most 29.3 versions with no problems.
Maybe it has to do with gpu/drivers.

Just make sure Eevee render settings screen space refractions and reflections are on, and the objects involved are all set to opaque, opaque on the shader settings.

I turned screen space refractions and reflections on, the object was set opaque, still no problem. There must be some other factor.
Edit: can you send a file to make sure all the settings are the same?

I have the same issue on Linux with GPU Intel integrated and the problem happens in the range between zero and 0.003

I think eevee uses GPU regardless.
My GPU is old (no optix or opengl) just plain cuda maybe that is related.

I just found this

Are you using intel integrated graphics?

1 Like

yes I have, I hope soon to buy a new laptop.

Well it looks like we found the culprit and it has been reported, hopefully it will get fixed.

1 Like