Complex Cloth Sim Freezes Blender! HELP Needed!

After using Blender for a few month, learning tons, fighting through issues and always finding a solution in the end - I really hit a wall this time. Hard. Huge bump on my forehead.
If anybody could help or point me in the right direction it would be greatly appreciated.
I really need your help here guys!

This is the problem:

I’m having several, ripped parts of clothes hanging on a character. Very few faces pinned, the rest hanging loose.
I did a first, rough test - and it worked very well.
Here’s a short clip:

Afterwards I refined the cloth and added some more pieces.
Obviously I was expecting to get some longer baking time.
But instead I got Blender to freeze completely. When baking it ‘pretends’ to work. But nothing really happens. Even after a full night. Cancelling the bake, is endless.
Caching by hitting the play button (or space bar) results in a spinning wheel, and Blender freezing.

I’m really surprised about this as the difference between the test and the refined version is not that big.

This is the test: (updated, I first posted a wrong picture here.)


The cloth here has about 5800 verts.
This baked without problems

Now the refined version:


Here the cloth has about 6700 verts.


It’s still not a dense topology. (yes, the topology won’t win any beauty contests - but it should not freeze blender!?)

In both versions I used only 1 subdivision (for render and for viewport).
While parts of the cloth in the test intersect with the collision body (the creature), in the refined version everything is perfectly neat and clean. I do have quite a few more pinned faces though.
Normals are all perfect in both versions by the way. (otherwise the cloth would go nuts.)

My first thought was to split up the cloth into two objects and bake them separately. But this doesn’t work either. It would not bake either of the halved object.
Somehow I must have created a problem for Blender, when refining the cloth mesh. But I have not the slightest clue what it could be.
And this is a major issue for me. Just as a thought I understood the challenges & little quirks of the cloth sim - I got slapped in the face! :sleepy:

I couldn’t find any help on the net.
So I hoped maybe some of you guys (and girls) have experienced similar issues and could have an idea what the problem might be?
Any help, even the smallest pointer, is greatly appreciated and will be rewarded with the dearest ‘thanks’ imaginable.

HELP!!! ANYONE???

Btw, I’m working with Blender 2.82 on an iMac Pro with 64 GB RAM.
Oh…and sorry for the long message. I’m actually glad if someone is still reading this line.

2 Likes

I don’t have an answer (sorry to trick you thinking this was a useful response! I’m having cloth issues myself :frowning: ), but I just wanted to say I really like the look of whatever youre making. It’s dark and brooding and creepy and pretty. And if you get this worked out, I would love to see the final version of whatever it is!

1 Like

I don’t mind getting ‘tricked’ with such kind words Arcarsenal. :wink:
Thanks a lot.

Unfortunately it seems, that no one has an answer to my problem, yet.
And in such a case Blender, as an open source software, shows one of its very few disadvantages - no support hotline. If I don’t find help in a forum like this - where can I get help? hmmmm…
Anyway, I’m still hoping some of the great artists here might stumble over this topic, knowing a solution.

Here are a few possible issues with cloth sim, I figured out:

  • make sure you don’t have double vertices at the same place. Merge vertices by distance removes this issue.
  • Make sure that normals are ok, when pinning a vertex group.
  • When baking, make sure that the subdivision modifier of the cloth is identical for viewport and render.
  • This seams logical, but it can still happen: when parenting cloth to an object/character - make sure the armature modifier is on top of the modifier list.

Those few notes so far solved all my problems…so far…

Hey JollyJumper,

I had the similar issue, where baking cache wouldn’t show any results. I clicked on “Delete all Bakes”, created a new cache by hitting on the plus icon in the cache sub-menu. Then I started new bake by hitting on “Bake all Dynamics”.
Are you willing to share your blend. file? Maybe you could post some screenshots of your cloth and collision settings.

1 Like

You should reword this post, you make it sound as if not only you couldn’t solve it, but nobody helped you. At the top you write:
Jollyjumped posted “Unfortunately it seems, that no one has an answer to my problem”

Something like:
I was able to fix the problem by:
Deleting duplicate verts, recalculating normals and making sure all modifier stack values matched for viewport and render, and then rebaking the simulation.

Hi Photox, sorry if this caused a misunderstanding.
But I was not able to solve the new problem so far. The solutions I listed are the ones which helped me with issues so far.
But the baking issue I was not able to solve yet.

I listed the other things, because Arcarsenal mentioned that he has problems with cloth, as well. So I thought those things might help other users.

OH, I was confused when you posted:
“Those few notes so far solved all my problems…so far…”

Can you post a blend, or a simplifed version of the blend?

1 Like

Hi Irakli,
thanks a lot for your suggestion. I tried it, but unfortunately it did now work for me.
The problem is, it doesn’t even really start to bake. It gets stuck instantly at 0 % and frame 2.

Here are the cloth and collision object settings:


Nothing really unusual in there, I think. Most of the values are actually default.

I’m not so fond of sharing the blend file. As it’s a scene for an unreleased feature film. :wink:

The test version with a few less verbs (a few less strands of cloth) bakes without problems. And the settings are identical.
I’m really clueless…

Try this:
delete the bake
save the file
save as, and rename the file to a new name cloth_ver_23.blend,
try baking again

1 Like

Thanks for the suggestion. Tried it several times. Unfortunately it also doesn’t work. hmmm…

Looks like I have to redo the scene. Still it would be great to know what caused this problem…as it might happen again…

Next step is start a completely new blend file, save it in a different directory as your original. Then append the entire scene into it and rebake. If that fails you’ll need to troubleshoot the simulation. Try appending the scene first.

1 Like

Also, especially on Windows, reboot your machine in case of corrupted or stomped memory.

Your settings for cloth and collision look fine to me… You have mentioned, that you’ve edited the geometry of the cloth pieces. I suspect that maybe you forgot to check your Pin Group. There is a chance that the vertex group looks completely different after the edit, which could also lead to such issues. I would try to reassign the vertices to a new vertex group and connect them to the pin group again.

1 Like

THANKS A LOT to everybody who helped me here. Especially PHOTOX!! :pray: :pray: :pray:
His solution did the trick! It’s baking as we speak! :grin:
Appending the whole simulation into a new blend file really solved my problem.
Seems like an easy fix - but stupid me did not think of it!
So thanks again a trillion times!

I still do not know what caused the issue, as I simply appended the creature with the cloth simulation without changing any settings. So it must have been something ‘under hood’ which got messed up in my files (and all the copies I made of it).

And I stand corrected - Blender does not need a support hotline!! The amazing users here take care of that perfectly!!

1 Like

Glad it worked out. It’s a bit dodgy, but when scenes start to barf appending the whole scene can clean out the cobwebs.

The character and cloth looks really great, by the way!

1 Like

is there any chance you would mind looking at my scene:

I can’t get it to work at all in 2.81, and even in 2.79, as soon as I include collision objects, it does the exact same thing as my 2.8 scene (immediately, before it even comes close to colliding with anything).

Sorry to hit you up directly, but I didn’t get any responses on my thread