Complicated pattern

Does somebody have an idea how I can achieve the pattern that covers the lower part of the watch? The only way I could think of is by using the array modifier on a plane and then manually adjust the squares. The downside of this is that it will probably take hours to finish. I can think of using of deform modifiers to put the planes in the right shape, but don’t exactly know how I could do it. Or maybe something completely different…?

Hint, that’s called a phyllotaxic pattern.

2 Likes

Two things that come up immediately when following @AlphaChannel 's advice:

I’m trying to implement something myself. Back when I have results or gave up :slight_smile:

Edit: another site for reference:
https://rose.telecom-paristech.fr/2020/11/22/generating-3d-models

3 Likes

Thanks for pointing out the direction.

So this is what I was able to do without studying the mathematics in detail:


This is generated by a blender 3.0 geometry node setup where I used the formula for the “flat patterns” here:

https://rose.telecom-paristech.fr/2020/11/22/generating-3d-models

to create a point distribution. Then I instanced a square on these points with the z-rotation and scale based on the angles and radii used to generate the points in the first place.

I did not work out the exact way to twist the squares into the shape needed such that they align perfectly, but played around with the vertices of the instance-square until it roughly worked out. A weld modifier takes care of the rest.

After applying the modifiers to the mesh, you get something you can work with, for example insetting every tile:

phyllotaxis_1_v02.blend (567.5 KB)

1 Like

Dont fit your needs precisly but this pattern reminds me what the spin modifier can do
spin_and_knife_project.blend (971.9 KB)

1 Like

This looks really good. But I think you uploaded an empty blender setup.

@Ren1
Works fine here,

download Blender 3.0,

Then add a cube,

Open geonodes editor and add the noodle.

play with count under the geonodes mod…

I didn’t have 3.0. Now it works. Awesome. Thanks for the help.

2 Likes

I just rebuild the node setup and encountered another problem. When I want to apply the modifier the whole object disappears. I did everything exactly as in AlphaChannels blender file. Does somebody know why this happens?

So the modifier works as advertised but when you apply it the object disappears? Can you share your .blend file where this happens?

Yes. Here it is.
phyllotaxis.blend (906.6 KB)

works fine on my end, which version exactly are you using? The 3.0 alpha build from here?

Yes. 3.0 alpha. When I apply the modifier the object is still selectable but there is no geometry. It’a like if I would hide all vertices in edit mode.

Just to make sure: what do you mean by “apply the modifier”? Do you mean adding the modifier to the object or clicking the “apply modifier” button?

I go to modifiers and hit strg+a to apply it. I need to do that to be able to futher edit the planar faces. Is that wrong. I just downloaded the 3.0 Alpha yesterday, so it should work fine.

I now downloaded the latest version and get the same issue, they must have changed something in the recent releases :frowning:

What is also interesting is that that weld modifier has no effect at all.

Luckily, there’s an easy fix: add a “realize instances” node right at the end:

(Apparently, they have changed how instances are handled in geonodes…)

1 Like

With the realize instances node I was able to apply the modifier. Do I always have to use this node if I want to apply the geo nodes modifier now?

I think the node is only necessary if instances are used in the node tree, if the final output node reads “geometry” it’s probably fine without the “realize instance node”.

Handling of instances should be more efficient than handling realized geometry, which is maybe why they made this change.

I’m just getting startet with geo nodes. All the new nodes that have been added can be a bit confusing sometimes, although there are quite the similarities to shader nodes.

Thank you. Looks like I can finally finish this project.

1 Like