Composite EXR File in Fusion 16 - Colorspace

I want to use Fusion 16 to composite my Attic Scene I posted a few weeks ago.

I use it the first time and get the software running and also use the filmic color space.

My problem:
When I use the channel boolean the color space turns back to linear and everything is too dark. Am I doing it wrong? The OCIO node works fine before.

In the image, I marked which node shows the correct color space and which not.

Thanks in advance!

Hi Christopher,
If you want to reproduce Blender’s appearance using Filmic in other software, you have to make sure that you’re using the same order of operations.
Basically, everything has to be done on Linear (more specifically linear rec.709) and the result will go through an OCIO transform. Remember that Blender applies Filmic as a “view” transform, meaning that it’s just applied on top of the compositor/render output for viewing purposes.

So, in order to fix your scene:

  • Load the linear EXR as-is, don’t apply any transforms. Data will stay in the original linear rec.709 colorspace.
  • Composite the passes
  • Put an OCIO transform only before the media-out Node, from Linear to Filmic (if you used other than base contrast in Blender for your reference you’ll have to use the FIlmic All-Views config from @troy_s as Fusion/Resolve don’t support OCIO looks.)

As a rule of thumb, always do your compositing on linear. Only move to display-referred data when you need to (that’s usually as a view transform for viewing or for final delivery to a display).

1 Like

Thanks for your response!
I will do it that way.

So the last question is how to apply the transform to the viewer, so I can see what I’m working on. For Example if I just want to adjust the diffuse color…

Trying to change the LUT, but I don’t know how to choose Filmic that way

Thanks for your help. Really appreciate that!

Use the ViewLUT option from the viewer context (or the grid icon). One of the options is OCIO colorspace.
There you can set Filmic All-Views or Filmic Blender OCIO config and choose from Linear to the desired filmic flavor.
Notice that when you do this you’re only applying Filmic to the view and your data stays linear.
Also, if you used an OCIO colorspace node before the media out node to move from linear to Filmic, the color transform will double-up if you preview from the media-out node (your colorspace node will apply filmic once, and the viewer will apply it again).

So, quick check:

  • If you’re going to stay in linear space but you want to preview with Filmic, use OCIO colorspace as view LUT.
  • If you want the result of your composite to be display-referred, add an OCIO colorspace node before the MediaOut (MediaOut will spit display-referred data). You can either pick the view from that node or media-out, or set a view LUT as described above in order to view the previous nodes through Filmic.


1 Like

Thank you so much for your detailed explanation!
I will give it a try.