Composite layers

in 2.8 I added the image and I don’t get all the layers when I upload an EXR image

in video it seems to work but not in 2.8
how can it be done ?

is this only for cycles or can work in EEVEE too ?

also is the mist created in the compositor or in the render ?

thanks
happy bl

Are you using MultiLayer OpenEXR? There are two formats.

yes I rendered with the EXR multilayers and saved it

but when I upload it in UV image it does not show all the layers like in video
which is strange
did you test it in 2.8

wondering if I have to render it in cycles or EEVEE !

thanks
happy bl

see set up here with EXR multi image from cycles

thanks
happy bl

Works for me in Cycles. I had already rendered an image with layers.
I didn’t have mist activated, but I had objID, matID, and crytpomatte.
Eevee doesn’t support passes, so I’m not sure if that makes sense.
In Eevee you appear to only get Image, Alpha, and Depth.
Not sure how the mist pass is setup, but I guess you can manipulate the depth pass using math and map range nodes.

how or where this mist is coming Is not really shown in video
but will redo test in cycles and see if I can get the image with all layers

thanks
happy bl

did new test got an EXR 25 MB for a very simple scene
tried it in compositor and cannot get the image multi layers

can you upload very simple file with Suzanne may be with composite nodes
and will see if it works on my Pc

there must be some parameters missing !

thanks
happy bl

Here you go.
Ricky.blend (2.2 MB)

Carl Thanks for sample file

but you use the render node
which does not have all the layers !

in video he is using the image node using multilayers EXR
I tested again in 2.79 cycles
and still unable to get what he did in video

thanks
happy bl

I turned off all other passes in order to be able to include a small sized .exr.
In passes. I’m not utilizing any layers. The “View Layer” layer (man…) is already the selected one the the file version where I add the mist. Same as in the tutorial, but he doesn’t show his whole node other than he has more passes activated.

Mist is a normalized depth output. You control the normalization in the world tab, and you can set the camera to show the limits. I’m guessing it’s outputted as a float and stored in the Mist channel at rendertime. If you want to use it, you have to do it in post.