Composite output losing 3D location

Object in Composite output is in front, instead of Middle of the object its over.

You can see from this image, that its sitting in front of the object:
http://lightwizzard.com/media/lw/light-wizzard-in-the-flesh/archive/0083-bad.png


it should sit in the middle, like this:



Such that the bottom of the Lightning is behind the block.

I couldn’t upload blend file; so here is the link:
http://lightwizzard.com/media/lw/light-wizzard-in-the-flesh/archive/0-logo.blend.zip

I’m using a RenderLayer Node, into three Blurr nodes, Add nodes to an RGB Curve node, then Add Node to compositor, changing the Add Node to an AlphaOver Fac 0, did not help, I’m at a lost for what to even try, not sure if its something I have to do in the Material or Texture, do not know where to start troubleshooting, and it makes me wonder about the other layers, although its not noticeable to me, I figure they are in the wrong place also; this looks like a bug to me, I can not imagine that it should be so difficult to composite.

This is the video of the effect I’m working on:
http://lightwizzard.com/media/lw/light-wizzard-in-the-flesh/video/light-wizzard-flesh.m4v

Thanks for any help.

enable ‘All Z’ for the ring layer and it’ll automatically mask out the top of the pyramid

That was it, I must have click the button off resizing the screen, because I was looking at some older videos and it was working.

Thanks, I would not have none what that actually does, so many settings, so little time to learn them all.

Another problem popped up, now the lightning in the other layers is masking out parts of this scene, where they cross it, my first though was to move them to the side when not using them, but there must be a way to make them transparent so this does not happen, simply turning off the brightness does not remove them from the scene, yet animating them off screen is easy enough way to fix it.

instead of changing its 3d space location
move it to an unused layer

Great timing, I was just coming back to update my post, I started to figure out that I could animate the Visibility Icon in the Outliner, I’m sure that Animating the layers is a better way to do it, since I’m compositing all the other layers, its just a matter of if I want to undo all the changes and try this… Yes, I think I’ll do it the right way, which would be the Animate the Layers, but the other trick worked also.

Thanks

Update: My brain was telling me test this first, and sure enough, moving it is a bad idea if you are compositing from the RenderLayer, which I am, so hiding in the Outliner is the only option I have, since Animating Layers physically moves it during the time the compositor is doing its work, thus render nothing. But its good to know this, now I know too ways to do this, and when to use what method.

I finally wrapped my brain around this concept of Hiding Layers and Compositing; well almost, but one Step at a time is what I always say, so I sat down and applied the technique, and it worked great; my original conclusion was that it wasn’t rendering through the composite node when its moved to another layer, which was correct, my problem was my layout was depending on other elements in that layer to finish that scene, that was my mistake, which led me to chasing demos by trying to hide all the objects, when one Layer should only include those element you want to animate during that scene; most people take that for granted, but not me, I had to learn the hard way.

Using the Visibility Icon to Key in objects is also a good technique, but its not as clean as moving layers, but has its own place in usefulness, in fact, it worked good in this situation, but was more work and not the right tool for the job, but if I ever need something to completely disappear and reappear without using its brightness control to fade it out, this is the tool.

I still don’t fully understand when to use All Z, but I do know that its the only way to keep its 3D location, but it also pointed out other flaws I setup in this scene, which was the overlay order, since these objects have Transparency set on, I was getting this funky outlines, I got rid of them by switching the inputs for the AlphaOver, which caused other problems dealing with the fact I still wanted the Projector in the middle of the Ball, in another project, so I had to work around, which was because I was working on two different projects at the same time and my multi-processor got confused, and I was trying to apply techniques that worked in one project, to another project, and got my threads mixed up, so instead of just editing it out, I thought there must be a good lesson to learn here, otherwise, this was all a waist of time, and that is how I got to this thread in the first place, thinking this is easy and someone here knows how, so I’ll ask, instead of spending hours fighting with something that I just could not see; so the lesson here was that I needed to separate my layers into scenes I could then connect to, using the Compositor, and then I could use the Top row for my Active Scenes and the Bottom row as my inactive scenes, then key them to be Active only when I need them, and learn to use AlphaOvers and Color Add nodes to get the right overlay order; I hope that helps clear up this thread I started and help others that find themselves in this same situation and find this thread to help them, I never like to leave a thread unsolved.