Compositing EEVEE - no Environment pass?

sooooo… how can i separate background in Render Layers panel?

My file has a World background node with strength of 0.500, so if i go transparent my scene is dark and
if i leave background it will just stack the more Rendered layers i have and get brighter.

Any workaround for this, tbh its my first time using compositor :slight_smile:

making transpart background won’t change scene ilumination. Everything should be lit the same as without the transparent background. If not report a bug or share the file.

I Also had the problems with rendering in eevee as it has no enviorment pass atm. The workaround I found was that you can duplicate the scene and change render settings per scene and then combine scene with transparent bg with just the bg. So basicly instead of using 2 render layers I used 2 exactly the same scenes.

1 Like

Oh, I just assumed it would remove it from affecting the render, thats good to know :slight_smile:
Also using 2 scenes so simple so clever!

Thanks this solved my problem!